How can I render Mantaflow (fluid) as particles, not mesh? (Blender 3.4+)

After rendering with Cycles engine, it should look something like the following (color based on speed, particles evenly spread, enough particles), but without the bounding box and axes:


It should also work like a regular scene (if for example I added a plane under it).

I've tried adding a cube, using the "quick liquid" action, baking to frame X, setting the material to transparent with volume absorption, and setting to render as halo in the particle settings, but this shows much less particles than the image.


1 Answer 1



  1. Quick liquid
  2. Set Physics --> Fluid --> Liquid --> Randomness (0), Narrow Band Width (10) 1
  3. Add --> Mesh --> Ico Sphere
  4. Hide Cube and Ico Sphere from viewport and render 2
  5. Liquid Domain --> Particle Properties --> Render As Object, Instance Object Icosphere 3
  6. Liquid Domain --> Material --> Transparent BSDF --> Surface 4
  7. Icosphere material --> Particle Info (velocity) --> HSV (value: 25) --> Color Ramp --> Emission --> Surface 5
  8. Liquid Domain --> Object Properties --> Visibility --> Ray Visibility --> Shadow (disable) 6

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .