Using cycles I have simple cut out people in the scene: planes with .png textures on them. The transparency shows in the material editor and is rendered correctly but is not displayed in the viewport. This isn't a single case, I haven't seen alpha showing in the viewport since I started using blender. See screenshot:

No alpha transparency in viewport

Today I took the time to investigate because it would be really helpful to see the cut out people with alpha when finetuning their placement in the scene. I found instructions on how to enable it in BlenderRender but not in cycles. I found some related things on blender sites - even here at StackExchange - but no real answer so far... It appears that alpha should show by default when in texture/material shading modes - so what's wrong in my system?

I use windows 7, Blender 2.73, ATI Radeon HD 4300/4500 Series

  • 1
    $\begingroup$ This works in 2.72 in material view for me. $\endgroup$ – VRM Mar 24 '15 at 14:57
  • 1
    $\begingroup$ have you tried another viewport alpha option unter settings (right bottom corner)? alpha blend and alpha sort may be, what you want. sorry if this is a little late $\endgroup$ – e-proxy Feb 9 '16 at 13:44
  • $\begingroup$ read: blender.stackexchange.com/questions/27633/… $\endgroup$ – user1853 Feb 10 '16 at 5:45
  • $\begingroup$ When using cycles, transparency will only show in the 3D viewport if the shading mode is set to Material or Rendered i.stack.imgur.com/ESNKR.png. Read: blender.stackexchange.com/questions/41060/… $\endgroup$ – user1853 Aug 11 '16 at 2:57
  • $\begingroup$ e-proxy : thank you! I'm now using Blender on a new computer but this has been still an issue. Untill I read your answer. It's just what I have been missing. Would you like to offer this as an answer to my issue? I'd like to accept it as the answer, maybe others will find it helpful in the future. $\endgroup$ – Booth Aug 19 '16 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.