1
$\begingroup$

I'm implementing a bone constraint for a racing game, to make the characters in the audience look in the direction of the leading car. I have it working in the character file (the character's head is following the empty target position) and when I lilbload/add the characters (and parent the targets to the car) the heads are correctly oriented. But as the game progresses, the bones never update, the characters heads stay in the same place as I move the target around...? And no error or warning in the console output...?

I made sure my target is correctly libloaded and parented to the real moving object (the car) with:

for people in logic.getCurrentScene().objects['People'].childrenRecursive:
    render.drawLine(people.worldPosition, target.worldPosition, [1,0,0])

And sure enough, a line is connecting each character to the moving object. The target works.

What I tried :

  • An "always" sensor (w/ or w/o "pulse") to an "armature" actuator, running either "run armature" (?) or "set target" or both
  • An "always" sensor (w/ or w/o "pulse") to a python module running logic.getCurrentScene().objects.get('Armature').update() at every single tick
  • Replace the "Damped Track" bone constraint with a "track to"
  • Removing all animations in the character file in case a keyframe is preventing the bone from moving

But nope, the characters head do-not-move as I move (applyForce) the car. Is there something like applyConstraint that I must use?

$\endgroup$
  • $\begingroup$ why not just use track to logic brick? it's simpler than python (I my mind) $\endgroup$ – Scalia Mar 24 '15 at 15:56
  • $\begingroup$ I forgot to mention this in the numerous things that I tried... $\endgroup$ – yPhil Mar 24 '15 at 16:06
  • $\begingroup$ so.. you tried [edit object]>[track to] ? and what was the result? $\endgroup$ – Scalia Mar 24 '15 at 16:08
  • $\begingroup$ Well, right now it does not work, which confuses me because last time I tried it rotated the whole armature... The thing about bones and logic bricks, is that the whole skeleton seem to share the bricks..? I mean, When I select the belly bone (in "Pose" mode) I can see the bricks connected to the head bone..? Another thing: If I want to do anything with my character (like set its worldOrientation to this of its "position" target) I have to wire it to an action actuator, even an empty (0 keys) one. $\endgroup$ – yPhil Mar 24 '15 at 16:38
  • $\begingroup$ Obviously I'm doing it wrong. Do you know an exemple of a Mesh+Armature libloaded in a scene, with a "track to" that works and updates in realtime? I'm really lost here, it's been days! $\endgroup$ – yPhil Mar 24 '15 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.