I am running blender on GPU. I remark that there is no high difference between CPU and GPU as not expected. What is the problem?

CPU information:

*

>     Architecture :        x86_64
>     Mode(s) opératoire(s) des processeurs : 32-bit, 64-bit
>     Boutisme :            Little Endian
>     Processeur(s) :       8
>     Liste de processeur(s) en ligne : 0-7
>     Thread(s) par cœur : 2                                                                             
>     Cœur(s) par socket : 4                                                                             
>     Socket(s) :           1                                                                            
>     Nœud(s) NUMA :       1                                                                             
>     Identifiant constructeur : GenuineIntel                                                            
>     Famille de processeur : 6                                                                          
>     Modèle :             26                                                                            
>     Nom de modèle :      Intel(R) Xeon(R) CPU           W3520  @ 2.67GHz                               
>     Révision :           5                                                                             
>     Vitesse du processeur en MHz : 1596.000                                                            
>     Vitesse maximale du processeur en MHz : 2661,0000                                                  
>     Vitesse minimale du processeur en MHz : 1596,0000                                                  
>     BogoMIPS :            5320.06                                                                      
>     Virtualisation :      VT-x                                                                         
>     Cache L1d :           32K                                                                          
>     Cache L1i :           32K                                                                          
>     Cache L2 :            256K                                                                         
>     Cache L3 :            8192K                                                                        
>     Nœud NUMA 0 de processeur(s) : 0-7

*
**GPU information:**



> *02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF104 [GeForce GTX 460] [10de:0e22] (rev a1) (prog-if 00 [VGA controller])
>            Subsystem: Gigabyte Technology Co., Ltd Device [1458:34fa]
>            Flags: bus master, fast devsel, latency 0, IRQ 53
>            Memory at bc000000 (32-bit, non-prefetchable) [size=32M]
>            Memory at c0000000 (64-bit, prefetchable) [size=128M]
>            Memory at c8000000 (64-bit, prefetchable) [size=64M]
>            I/O ports at 2000 [size=128]
>            [virtual] Expansion ROM at be000000 [disabled] [size=512K]
>            Capabilities: <access denied>
>            Kernel driver in use: nvidia
>     
>     02:00.1 Audio device [0403]: NVIDIA Corporation GF104 High Definition Audio Controller [10de:0beb] (rev a1)
>            Subsystem: Gigabyte Technology Co., Ltd Device [1458:34fa]
>     --
>     03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
>            Subsystem: ASUSTeK Computer Inc. Device [1043:8354]
>            Flags: bus master, fast devsel, latency 0, IRQ 54
>            Memory at b8000000 (32-bit, non-prefetchable) [size=16M]
>            Memory at d0000000 (64-bit, prefetchable) [size=256M]
>            Memory at ce000000 (64-bit, prefetchable) [size=32M]
>            I/O ports at 3000 [size=128]
>            [virtual] Expansion ROM at b9000000 [disabled] [size=512K]
>            Capabilities: <access denied>
>            Kernel driver in use: nvidia
>     
>     03:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be3] (rev a1)
>            Subsystem: ASUSTeK Computer Inc. Device [1043:8354]*

Path tracing sample is 1000.

I tried the GPU with tile size=256, 512, 1024 and with 500, 250, 150 samples but I remark that for 2hours or 3 hours, it rendered only 66 frames. It is very slow!!!

closed as off-topic by ideasman42 Mar 31 '15 at 23:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is too localized in its current form and is unlikely to be applicable outside of a very narrow context. Consider broadening the scope of this question in order to make it more useful for future users of the site." – ideasman42
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    What GPU and what CPU? – gandalf3 Mar 23 '15 at 19:47
  • 1
    what GPU do you have? – Denis Mar 23 '15 at 19:47
  • 4
    What is the size of the rendering tiles? how big are your textures? what kind of GPU are we talking about? what kind of CPU? how much RAM?, does the scene involve physics or particles? It's hard to guess what you are doing and what your expectations are. Please add more info to your question. – cegaton Mar 23 '15 at 19:53
  • That is almost the same GPU/CPU that I have, and my GPU is definitely faster. What tile size are you using then? GPU's generally go faster on larger tiles and slower and smaller tiles. CPU's tend to do the reverse. – gandalf3 Mar 23 '15 at 20:05
  • @gandalf3, path tracing sample is 1000. – BetterEnglish Mar 23 '15 at 20:11