12
$\begingroup$

I followed this tutorial ( https://www.youtube.com/watch?v=2KNO_laPA9s ) to create an audio visualizer, and it's worked great with the audio baking to the curves to affect the particles.

But during the render process Blender has crashed a couple of times. On resume I have to play the animation again to repopulate the particles and create a new animation.

The audio-to-fcurve bake remains intact in the .blend file, but the particle generation and turbulence isn't baked into the blend the way a physics simulation would be. I have BVH caching enabled, but I guess that's not persistent since the randomness of the turbulence results in variables between sessions that prevent me from continuing smoothly at the last frame rendered before the crash.

How can I ensure that the data is consistent between renders of the animation?

$\endgroup$
  • $\begingroup$ BVH caching is for rendering. BVH stands for "Bounding Volume hierarchy". This is basically a "map" of the scene which cycles uses to navigate photons around. It is kind of odd that the particles are behaving differently though.. AFAIK they should be the same unless you changed something. $\endgroup$ – gandalf3 Mar 23 '15 at 19:39
10
$\begingroup$

You can bake the particles by going to the cache section on the particle emitter. Enable Disk Cache and then Bake All Dynamics. After you do that save your file. The particle cache info will be saved to disk.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks :) Don't know why I missed that. It sure it slow compared to rendering. It will likely take a couple of days to cache this 6000 frame animation. $\endgroup$ – Casey Wagner Mar 23 '15 at 18:45
  • $\begingroup$ @CaseyWagner That's odd... It should be almost the same as playing through the animation as you were before (the only extra time needed is for writing the data to the disk) $\endgroup$ – gandalf3 Mar 23 '15 at 19:37
  • $\begingroup$ Well, I baked all dynamics, and began rendering the simulation. It went well for three hours but then crashed. (The crash log file contains no information, so isn't relevant) When I opened the Particles properties I chose to load the external cache but it's giving me "No valid data to read!" So I'm stuck where I was before. Urk. $\endgroup$ – Casey Wagner Mar 24 '15 at 5:45
  • $\begingroup$ Ah ha! I stopped using the external option, baked the particles directly into the blend and saved it immediately. That allowed it to persist after the last crash. :D $\endgroup$ – Casey Wagner Mar 24 '15 at 13:29
0
$\begingroup$

You have to have "Hair Dynamics" ticked apparently. Then the cache section appears.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.