1
$\begingroup$

first time try to make hair, i watch from tutor in youtube is kinda simple so i tried. when look in viewport is looks good for me but when i render. it looks balding

viewport shading

viewport shading

sample render

enter image description here

here is my blend: https://drive.google.com/file/d/1ncxZb3nHmK_61vQGB80oq7fm-OeDmUne/view?usp=sharing

$\endgroup$

1 Answer 1

1
$\begingroup$

The difference comes from the fact that hair diameter is hadled differently between Eevee and Cycles, and Viewport rendering is Eevee based.

In Cycles you can set the scale of the diamater in the Hair Shape tab of every particle system, so a quick solution is to alter this value as I did in the left side of my example.

For a solid workflow you should Apply Rot and Scale (Ctrl A) before using particle systems or any other function and modifier that relates to real world measures: in your case the 0.008 scale makes troublesome to use default values on the particle hair system, but if you Apply scale now, you will have to rework your hair particles from scratch.

enter image description here

$\endgroup$
3
  • $\begingroup$ I could save the edit. Just hit the Disconnect Hair button first to disconnect both hair systems, then apply Rotation and Scale to the head, and finally Connect Hair again. Also, make sure you set Eevee > Curves > Shape to Strip as described here: blender.stackexchange.com/a/210751/107598. Note: The Hair > Hair Shape Type option is renamed to Curves > Shape in Blender 3.1 and later. $\endgroup$
    – Blunder
    Sep 24 at 8:20
  • $\begingroup$ Thank you Blunder for the interesting information! $\endgroup$ Sep 24 at 8:25
  • $\begingroup$ thank you its really helpful for me $\endgroup$
    – nemeshine
    Sep 24 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.