0
$\begingroup$

I created a shape key for this character. The original shape key was placed on his left eye. I then mirrored it by topology. For some reason, it affected his tongue. So now when I activate the driver to get his right eye to blink, part of his tongue gets deformed for some reason.

enter image description here

I wanted to know if there was a way to make the tongue geometry unaffected by the shape keys. Here is the link to the file: https://www.mediafire.com/file/83ncatlgc54no1k/Mega_Man_Blend-Exchange_Blink_Problem.blend/file

$\endgroup$

1 Answer 1

0
$\begingroup$

Select the uncorrect shape key, go to edit mode, select the vertices that should not move, go to menu Vertex > Blend from shape.

In the black box of the last operation properties (left bottom of the window, press F9 if it disappears) select the "Basis" shape key, leave the default value of 1 and uncheck the "Add" option.

enter image description here

enter image description here

Another method is to go to edit mode, select all vertices that should move, press Ctrl G to assign them to a new vertex group. Name it something like "Affected", then in object mode select the shape key and set Affected in its vertex group field.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .