0
$\begingroup$

I am trying to animate bones of an armature (my goal is to export an FBX with my animation with just 2 frames). I have a Rest Position of a t-pose and a Pose Position of laying on the ground.

In the Animation view I enter Pose Mode, select Rest Position, select all bones and go Insert Keyframe -> Location, Rotation & Scale.

Then I move the timeline to frame 5, select Pose Position and Insert Keyframe -> Location, Rotation & Scale.

When I drag the timeline it does not animate between my 2 keyframes. It just shows whatever pose I have selected. Why?

If I enable recording and rotate a specific bone it records it properly - when I play the animation in the timeline the bone rotates between keyframes.

enter image description here

enter image description here

enter image description here

Blender 3.1.2.

$\endgroup$
3
  • $\begingroup$ Can you upload the file via blend-exchange.com? $\endgroup$
    – Lowlande52
    Sep 23, 2022 at 5:24
  • $\begingroup$ No - it includes licensed content :( $\endgroup$
    – Jared
    Sep 23, 2022 at 5:54
  • $\begingroup$ Did you check the Nonlinear Animation editor? $\endgroup$
    – 3DBear
    Feb 10, 2023 at 15:27

1 Answer 1

1
$\begingroup$

Change armature pose mode to “pose” (not “rest”).

On the first frame, select all bones in pose mode and press alt+g, alt+r, and alt+s to reset rotation position and scale; then press “I” and set record key frame, and from that menu select the option with rotation, position, and scale.

Scrub to second frame to confirm the pose works and you should be good to go. Be sure to have animation checked while exporting to fbx.

Welcome to blender!!!

$\endgroup$
3
  • $\begingroup$ You have suggested exactly what I have already done. $\endgroup$
    – Jared
    Sep 23, 2022 at 5:52
  • 1
    $\begingroup$ That "Rest Pose" button overwrites any posed bone, showing you the rest T pose, but internally every bone mantains its original values of loc, rot and scale, so when you hit I you're storing thoose laying posed values, not the rest one. This is visible in dopesheet also, where the lines between keyframes show us that the values are the same, so no move occours. So, as suggested by Lowlande52, go to one of the keyframed place, select all bones, press Alt G, Alt R, Alt S, then I to insert a keyframe for the real rest pose. $\endgroup$ Sep 23, 2022 at 10:27
  • $\begingroup$ Just for the sake of rephrasing to reach more people: The Rest Position is not animatable nor keyable. But the Rest Position is what you get in Pose Position when resetting your controllers to their default pose via Alt G/R/S. So, stay in Pose Position, go to a different frame and reset all your controllers and key that down. $\endgroup$
    – Lauloque
    Feb 15, 2023 at 14:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .