3
$\begingroup$

I'm trying to get rendering of a basic cube to have sharp edges. I'm testing with a basic cube that uses a default Principled BSDF material with a purple base color. Here's a rendered asset, its size is 115 x 115

enter image description here

The edges and corners look a little too "fuzzy" or "soft" for the look I'm going for, ie when I zoom in, there are more translucent pixels at the edges than I want. Zooming in on the lower-left corner of the rendered asset, with black background added to better illustrate, you can see there's a 1px translucent pixel column on the left for example:

enter image description here

Is there any way I can make the edges render "sharper"? I can't increase the resolution, my assets need to be this exact size for my application. Also when I create the same asset with an svg editing app like Illustrator, and export the same size to png, the edges do come out sharper, so I think there's something I can do with the material in Blender maybe to match what I want,

Thanks

$\endgroup$

1 Answer 1

4
$\begingroup$

You can adjust filtering settings in the Properties Editor, Render tab, Film section:

enter image description here

Lowering the filtering size or width removes anti-aliasing effect, but also makes diagonal lines look uglier.

$\endgroup$
2
  • $\begingroup$ thank you - this is a property that affects the whole scene, do you know if there's something similar that can be applied per object? $\endgroup$ Sep 28, 2022 at 11:34
  • $\begingroup$ As far as I know there is no functionality that would allow that per object in Blender. $\endgroup$ Sep 28, 2022 at 11:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .