I'm developing games with the Defold game engine, and someone in the engine's community have made a blender addon to export a .blend into files that the engine can understand, so that the workflow between blender and the engine is better, for a lot of reasons is veeeerry unpracticle to take .dae and use it on the engine, specially bc the engine only accepts one mesh and one texture per mesh. Anyway, THE PROBLEM IS that whenever i want to export a .blend for Defold, the extension just doesnt! I mean, it wont export if the export directory is in Desktop, it exports just fine for any other file that is not inside Desktop. So it exports to Documents, Users, Downloads... but won't do that with Desktop. For the addon to work, blender should be ran as admin, aswell as the luajit program the addon uses should too and in my case both are ran as admin. But still, the addon doesnt export a thing if it is for the desktop. I and the creator of the addon (called Defender) have been chatting ever since august to solve this problem, but nothing that we tried works. I deleted OneDrive as it was a supposed as a reason it wasnt working, still nothing. The creator tested in Win10 and 11 and said it worked fine. Our suspicious is that my OS (or even i myself) have messed the permission level of Desktop. But nothing is confirmed, it could also be only Blender or a Python script that just isnt working. Any help is appreciated.

The following images show that even tho the addon declares no errors and that it succeeded, nothing was done ("Área de Trabalho" means Desktop in portuguese)

Note in the title bar what is the path of this blender project

enter image description here

And now after the export, nothing is done! enter image description here



You must log in to answer this question.

Browse other questions tagged .