I downloaded a simple wood texture and am trying to apply it to this bowling lane. I got node wrangle to set up the nodes for me, and then did a UV wrap projected from top view. In material preview it looks completely fine, but for some reason rendered view makes it looks atrocious Material Preview

Rendered view

UV wrap

I did admittedly do some meddling with the mesh earlier in the setup. I had the lane you see there split into two pieces then re-joined. I don't know if this would affect it though, and I had no idea the texture could run off the mesh or look different to material preview


Any help is greatly appreciated

  • $\begingroup$ @moonboots That should read pack your images! File > External Data > Pack Resources. :^) $\endgroup$
    – John Eason
    Sep 7, 2022 at 8:10
  • $\begingroup$ oops sorry yes, could you please pack your image and share your file: blend-exchange.com $\endgroup$
    – moonboots
    Sep 7, 2022 at 8:31
  • $\begingroup$ @Confused_User A texture cannot show up in "empty space" without a mesh. It just looks like that in Rendered view because the outline of the selected object shows the object as it is without some modifier that becomes visible in render and produces this outstretched version of the object. There is a modifier on the "Lane" object, which one is it? You're not showing that in the screenshot. $\endgroup$ Sep 7, 2022 at 8:37
  • $\begingroup$ If I see the material correctly, you have some displacement there. This for example is something that changes the geometry in rendered view but shows the outline of the unchanged geometry. $\endgroup$ Sep 7, 2022 at 8:57
  • $\begingroup$ @GordonBrinkmann There was an array modifier on the lane but even when I remove it the texture runs off the mesh. It also has a rigid body simulation passive on it, but that shouldn't change anything $\endgroup$ Sep 7, 2022 at 21:56

1 Answer 1


You're using a Displacement node, it displaces the topology and can only be seen in Renedered preview, unplug it, or in the Material > Settings > Surface > Displacement, choose Bump Only, or if you want it to work properly, apply the scale and subdivide your object :

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .