1
$\begingroup$

I'm new to Blender and these problems had been bothering me for two days.

I'm creating a female character and trying to add armature to it. I used the armature deform with automatic weight to parent the body and bones but it did not work. The body layer goes under "rig" but the body does not follow where the bones go. There are lots of vertex groups shown in the body's data properties so I'm pretty sure the body is rigged but it just couldn't move.

Also, I cannot see anything in the weight paint mode. I've tried auto weight and envelope weight but they are both not working. I've selected the body and the armature but after I "weight" them, the whole body becomes purple after I select any of the bones.

Any suggestions will be appreciated. Thank you so much!

The blender file is here https://we.tl/t-kF6Z2tkgF0

enter image description here The face comes out directly, rigging didn't work

enter image description here I tried both auto weight and envelope weight but they both won't work

enter image description here After weighting, the whole body becomes purple after I select any of the bones.

$\endgroup$
6
  • $\begingroup$ Hi Jess, i tried now several things, honestly, i don't know why your rig doesn't work. But...your project is pretty difficult to "understand". 1) You have 3 bodies (you should hide all not used bodies in a collection and maybe call it "hidden" so that you don't click on an unwanted body). 2) in the python info window you get this error: [1]: i.stack.imgur.com/4pAqB.png -> this shows that Blender has a problem rigging your body 3) you can search for this error message here and you get this answer: $\endgroup$
    – Chris
    Sep 6, 2022 at 13:05
  • $\begingroup$ blender.stackexchange.com/questions/15964/…. pls read that and use that. If you just did "seperate by loose parts" on your mesh, i got over 6 different parts...And i don't know where you got your rig from, but if i enable "rigify" and use the "normal" metarig on your (one) body mesh and scale it and move it a bit, it works by parenting armature to the mesh and then choose automatic weights $\endgroup$
    – Chris
    Sep 6, 2022 at 13:07
  • $\begingroup$ and if you are new to blender, honestly, i would try a much simpler mesh with simple armature (not human rig) just to learn and understand the basic principles. And watching good free tutorial on yt help a lot too! Happy blending! $\endgroup$
    – Chris
    Sep 6, 2022 at 13:09
  • $\begingroup$ In this case, they are probably failing because of a combination of two things: small scale (1m = 1 unit scale, 1m = 10+ units is better for autoweights) and high vertex density. Even if you got autoweights working, this is too many verts for armature deformation; it would be unusable. Additionally, edge flow is non-existent. Retopo the model. $\endgroup$
    – Nathan
    Sep 6, 2022 at 16:02
  • $\begingroup$ Just curious, have you used a base mesh to sculpt the model? It looks like a sculpture with all these triangulated faces. As Nathan wrote, such a mesh is bad for animation because it's very heavy (=poor performance) and will deform badly. You need to retopologize it to create a light version of it. $\endgroup$
    – Blunder
    Sep 8, 2022 at 9:42

1 Answer 1

0
$\begingroup$

The main problem you run into here is that you use a sculpted mesh. Such a mesh is created for portraits and to get the overall shape of the character. It's not suitable for texturing and animation because it's very dense and requires a lot of data and calculations.

For animation, you need to create a lightweight version of the mesh. This process is called retopology.

If you enable the wireframe overlay you will see the difference between the sculpted mesh and the retopo mesh. It's roughly 280,000 vertices vs 8,184 vertices.

sculpt vs retopo mesh

I've done the retopology for the head. The rest I've frankensteined from a basemesh, feet and hands. I've noticed that the hands of the base mesh have a few triangles and the feet have a few 6-star poles. No biggy, they are at spots you will not see them and where the mesh does not deform a lot. But I've decided to replace them. In hindsight, I could have simply used the MBLab body.

You can use the Grab, Elastic Deformation, Smooth and Pose brushes from the Sculpt mode, and a Shrinkwrap modifier to shape the base mesh according to the sculpture. With vertex groups, you can limit the effect of the Shrinkwrap modifier to certain areas. Sometimes it creates glitches but with the Snap option enabled, you can fix them manually in Edit mode. Just grab the bad vertex and it will snap to the nearest face. Clothing can be adjusted in the same way.

Also, consider reducing the number of vertices of the eyes and the eye-glass objects. They have 35,000 and 44,000 vertices for each eye. With the Decimate modifier you can Un-Subivide the eye 8 times and it will have only 157 vertices with 12 segments. Add a Subdivision Surface modifier and it will look fine with only 5000 vertices at render time (level 2).

low-poly eye

Before you start to rig the meshes apply the Rotation and Scale to the objects (Ctrl+A) in Object mode. For the body mesh and the metarig also apply the Location. This will reset the values in the side panel to (0°, 0°, 0°) and (1.0, 1.0, 1.0).

Also, check the Face Orientation. Applying a negative scale (eyes) will flip the normals and the object is inside-out. You need to flip the normals in Edit mode (Alt+N to correct them.

eyes, scale, and rotation

The Parent To > With Automatic Weights works well except for the eyelids and the mouth. These parts need manual weight painting. Also, the eyeballs, upper and lower teeth need to be children of the eye/teeth bones (Parent To > Bone in Pose mode). If you use Blender 3+ make sure you have upgraded the face rig. There is a button near the Generate Rig button to do so.

You can turn off the Subdivision Surface modifiers anytime when you need to reduce the number of vertices in the viewport to get better performance. On the Render Properties there is the Simplify option that can disable all Subdivision Surface modifiers when you set the Max Subdivision value to 0.

One last thing. Her arms are too short. The distance between the fingertips in T-Pose should roughly equal the character's height. She is 1,65m tall but her arms are 1,40m short. But no worries. The low-poly mesh allows you easily to make her arms longer.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.