0
$\begingroup$

The attached Blender file is setup to run with the physics engine.

When I run it, the wormgear does not spin, and the wormgear and wormwheel seperate.

Can anyone offer any suggestions?

$\endgroup$
9
  • $\begingroup$ Hi B.Teddy, although i don't wanna kill your illusions, but i am pretty sure that nearly every gear animation is just realized by drivers or/and keyframed animations and not by physics. $\endgroup$
    – Chris
    Aug 29, 2022 at 7:10
  • $\begingroup$ Have a look at the tutorial: youtube.com/watch?v=jVtr80IF-yI @12:42 time location. $\endgroup$
    – B.Teddy
    Aug 29, 2022 at 8:43
  • $\begingroup$ It's been a long time since I last tried to do any gear simulations so I don't think I can fix it... but there are a few things problems which I immediately see in your file: the wormgear and wormwheel meshes overlap - that's always bad. The origin of the wormwheel is somewhere in the wormgear, that's definitely bad as well. //EDIT: Didn't see the tutorial when I wrote the comment. Doesn't seem to be a problem there, but that's strange. Rigid body physics break quite easy with incorrect origins and overlapping geometry. $\endgroup$ Aug 29, 2022 at 8:54
  • 1
    $\begingroup$ I have to ask: how thoroughly did you follow the tutorial? It doesn't look like there's overlapping geometry. Also, at 15:10 the first test doesn't work because the worm has inverted normals which are corrected with Shift+N, but you didn't even fix that in your model. $\endgroup$ Aug 29, 2022 at 9:08
  • 1
    $\begingroup$ Yeah also the worm gear part still has it's collisions set to Convex Hull. Go back and make sure you follow the complete tutorial. $\endgroup$
    – Jakemoyo
    Aug 29, 2022 at 10:38

1 Answer 1

0
$\begingroup$
  1. set the collision shape of your worm gear to mesh

  2. the worm gear has wrong normals, which you can see if you click on "viewport overlays" and check "face orientation". All red faces have wrong direction. Physic simulation will nearly always fail if any involved object has wrong normals. Correct them by selecting the worm gear, TAB -> edit mode, A -> select all, Shift-N. Then the worm gear will turn blue (he explained that in his video - you seemed to have skipped that too)

  3. Looks like you also didn't follow the step "merge by distance" (always(!) follow each step exact (!) as the tutorial does (as long as you are not experienced in what you are doing - else you will fail. I know this from my own experience and i failed often following tutorials) -> select your worm, TAB -> edit mode -> A -> select all -> M -> merge by distance ->

enter image description here

  1. for better looking i would recommend select the worm gear -> right click -> shade flat

enter image description here

  1. change your settings here :

enter image description here

and uncheck "origins". Else if you move things with G you will not move the objects but just their origins.

  1. press 7 and you will see:

enter image description here

so you made it somehow that your axis1 is not centered to your gear and by this the motor won't work correctly. So select axis1 -> object -> set origin to geometry, then in transform set x and y to 0

enter image description here

then it should look like this:

enter image description here

enter image description here

check with 7 whether now it is centered and it should be

  1. delete object you called "worm"

  2. you didn't choose your objects for your motor:

enter image description here

so select your motor empty and choose these:

enter image description here

  1. select your worm wheel: do you see the orange point? (left of the red/white circle)

enter image description here

this is the pivot point and the center of mass. This should be in the middle of the wheel. So in object mode -> object -> set origin -> origin to geometry

enter image description here

  1. if you press 7 again, you will see: even your worm gear isn't really centered :(

enter image description here

so same procedure: object -> set origin to geometry, set transform x and y to 0

enter image description here

  1. in edit mode, scale it down just a little bit :

i scaled:

enter image description here

and change motor settings to:

enter image description here

and you will get

enter image description here

My recommendation: start the tutorial from scratch. Follow each and every step exactly. Don't move things in edit mode if tutorial moves in object mode (and yes, this makes a HUGE difference because by moving objects in edit mode you change the origin of the object in relation to the mesh). Then it should work.

Good luck and happy blending.

Watching some beginner tutorials would help you too because you made a lot of beginner mistakes (which we all made, and i made them 3x in my beginnings) and to be honest: That tutorial is not really for beginners because it is too fast, to bad explained and often not clearly visible for beginner to see what he is doing)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .