1
$\begingroup$

I'm trying to make a simple collision between 2 chess pawn. One is animated and the other is not. enter image description here I made the basic rigid body settings but the animated pawn is just passing through the other one. This is the setting for the animated pawn then the setting for the not animated one.

enter image description here

enter image description here

I don't understand where is the problem from..

Thanks a lot !

$\endgroup$
5
  • 1
    $\begingroup$ pls provide blend file, thx $\endgroup$
    – Chris
    Aug 25, 2022 at 12:32
  • $\begingroup$ here it is, its not in the main scene but in the scene.001 : we.tl/t-PRSxMmeyTK $\endgroup$
    – a33
    Aug 25, 2022 at 12:39
  • $\begingroup$ hello, maybe make a file with only the important objects $\endgroup$
    – moonboots
    Aug 25, 2022 at 12:55
  • $\begingroup$ there is only the important objects in the scene 2 of this file $\endgroup$
    – a33
    Aug 25, 2022 at 12:59
  • $\begingroup$ @a33 Yeah, and all the objects in the other scene which makes this file unnecessary large. $\endgroup$ Aug 25, 2022 at 13:15

1 Answer 1

0
$\begingroup$

You've messed up the Rigid Body World a lot, not sure what steps you did to get there but here's how you get the animation working:

  1. Remove the Rigid Body physics from all 3 pawn objects, "Petite cailles.017", "Pied cavalier.003" and "Moto1.003" as well.
  2. Select them all (or at least the motorcycle and its pedestal) and press Ctrl+A > Apply > Scale.
  3. Go to Scene Properties > Rigid Body World and click on Remove Rigid Body World.

remove RBW

  1. Go to the Outliner window, switch the Display Mode to Orphan Data in the dropdown menu at the top, expand Collections, select all that are called "RigidBodyWorld..." by shift-clicking on them, press X to delete them.

delete orphans

  1. Now add Rigid Body physics to the pawn objects again. Remember to set the motorcycle objects back to Animated.
  2. Go to the Scene Properties > Rigid Body World again. The End value is at default 250 again, set it back to 950. Press Delete All Bakes (this is important, although you've delete rigid bodies before, there might be a cache stored somewhere).

delete bake

You could now press Bake or Bake All Dynamics or run the animation from frame 1 and the rigid body simulation would work - which in this case would mean the unanimated pawn would fall through the floor. So I suggest adding another step ;)

  1. Enable rigid body physics on the chessboard object "Chessboard.002" as well, set it to Type > Passive.
$\endgroup$
4
  • $\begingroup$ Thank you so much you literally saved me ! $\endgroup$
    – a33
    Aug 26, 2022 at 12:03
  • $\begingroup$ I'd forgot the Orphean Data thing for reseting the rigid body world it will help for a lot of project ! $\endgroup$
    – a33
    Aug 26, 2022 at 12:04
  • $\begingroup$ @a33 Glad I could help. Would you mind considering to accept the answer then? $\endgroup$ Aug 26, 2022 at 12:13
  • $\begingroup$ sorry i've forgot about that as well $\endgroup$
    – a33
    Aug 26, 2022 at 13:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .