I've attempted to create and rig a character from Baymax today and I've run into an issue where my rig doesn't follow the bones. Attached is a complete view of all of the bones, the weight paint for that bone, a video of me moving the bone, and the Blend file. The expected outcome is that each bone should be able to move the designated part of the mesh completely and not deform or shrink. I am also intending this for use on the Roblox platform.

Thank you so much for your help!

Complete view of all bones

Weight paint for the bone in the video


Blend file

  • $\begingroup$ hello, please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Commented Aug 25, 2022 at 3:11
  • $\begingroup$ You do have an Armature Deform modifier on the mesh with the armature set as the target, right? $\endgroup$
    – TheLabCat
    Commented Aug 25, 2022 at 4:37
  • $\begingroup$ To add to Chris' answer, you can parent With Empty Groups, and assign the vertices to the vertex groups they are supposed to be part of $\endgroup$
    – moonboots
    Commented Aug 25, 2022 at 6:23

2 Answers 2


select your mesh, shift-select your armature -> press CTRL-P -> with automatic weights. Problem solved.

If you want that one bone just moves one part, you have first, to separate your meshes to this "single" moving parts. Then select e.g. the arm-mesh, shift select the armature, change to pose mode, choose your arm-bone and then CTRL-P -> Bone. Repeat these steps for all single meshes + corresponding bones.


Mesh doesn't follow bone because vertices are assigned into a more vertex groups ...

Like this part is assigned at the same time to the Bone, Bone.001, and Bone.002 ... it means each vertex position is influenced by average of those three weights.

enter image description here

Should be assigned only to Bone.002

You can fix that by setting to other Bones > Vertex Weight > zero, than press icon next to a number (Copy to Selected).

Or delete all Data Properties > Vertex Groups and with plus button create new groups. Just select appropriate vertices add group click Assign and name the group my bone name. Like that you don't have to separate mesh into solo objects.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .