Can anyone help me with it as converted into mesh creating multiple points/vertices than less vertices geometry path which will make my old system less laggy

I selected a plane, added a particle system, and selected Hair. Under Render I changed Path to Object and under Object I selected NurbsPath in the Instance option as shown in a YouTube video.

In the video, it appeared instantly on the plane but to me, it was not appearing.

So here is what happened to me in this query:

  • First I take a Nurbspath from Shift+ACurvePath

  • Then taken a BezierCircle, same as above.

  • Then changed the geometry of the NurbsPath in Object Data Properties to BezierCurve and modified the path as grass in Edit Mode.

  • Then added the plane to use as a ground for grass.

  • By selecting the plane added hair particles in Particle System.

  • Then in the Hair tab options went to the Render option and changed the instance as Object and in the newly appeared Object option below the render option I selected the NurbsPath (as shown in the image below).

Then instead of the plane having the NurbsPath in place of the hair, the plane appeared empty as appeared in the below image.

And I did this all by following a YouTube video in step by step process as shown in it. In that video, it appeared but for me, it didn't.

So, what was the mistake I have done here, and how to rectify it?



  • $\begingroup$ Can you post the link to the mentioned video? $\endgroup$
    – Blunder
    Aug 24, 2022 at 18:30
  • $\begingroup$ Your particle scale is tiny, make them bigger $\endgroup$ Aug 25, 2022 at 11:06
  • $\begingroup$ Link to the video i mentioned = youtu.be/C_DPPYqw7Zs can u check and give me a solution @Blunder $\endgroup$
    – Ramos
    Aug 25, 2022 at 11:10
  • $\begingroup$ I have increased the scale number to 3000 from 0.50 as u suggested but still didn't worked @Duarte Farrajota Ramos $\endgroup$
    – Ramos
    Aug 25, 2022 at 11:13
  • $\begingroup$ Hi. I've followed your instructions and got the same result in Blender 3.2. Now I've watched the video I've noticed the tutor uses Blender 2.92. So I've opened the file in 2.93 LTS and there it is! It's the Blender version. Blender 3.2 got new a new curve type that wil replace the existing curve types (poly, bezier, nurbs) and the hair particle system. Maybe these changes broke something and you can't render particles as curves now in 3.2. $\endgroup$
    – Blunder
    Aug 25, 2022 at 12:19

2 Answers 2


I think you have to convert your NurbsPath to a Mesh :

Select NurbsPath press Ctrl + A and choose Apply > Visual Geometry to mesh

Maybe there's a way to directly render NurbsCurve, but I doubt it.

  • $\begingroup$ Ok, i will try that, in the video i followed he didn't do anything like this and it appeared for him but i followed step by step of that video still didn't appeared for me, why was it like that $\endgroup$
    – Ramos
    Aug 24, 2022 at 11:25

Blender 3.5. I ran into this issue as well. For whatever reason, the nurb path object needs to be converted to a mesh. Right click on the object and convert to mesh. This is the workflow I am using now.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .