When I try to render my scene in Blender, it will only render on gpu, not cpu. I went to the preference tab to see what settings I could change to make it work, but I was greeted to this:It doesnt recognise my gpu as compatible in any of the tabs

I've tried updating to the most recent version of Blender and GPU drivers. Specs: RX 580 16 GB ram Ryzen 5 2600

  • $\begingroup$ What happens if you switch to CUDA? - My own RTX 2070 gives the same error message if I click 'HIP' so you'd need a much higher spec graphics card to use HIP. $\endgroup$
    – John Eason
    Aug 24, 2022 at 10:14
  • $\begingroup$ @JohnEason I have indeed tried switching to all of the render devices and none of them get found. Also I thought CUDA was Nvidia? I'm using an amd gpu. $\endgroup$
    – frostproto
    Aug 24, 2022 at 10:23
  • $\begingroup$ Sorry. You're correct about CUDA and Optix being Nvidia only, however your gpu doesn't seem to be capable of using HIP according to this in the Blender manual. Best to check on AMD's web site to see if your gpu is supported. $\endgroup$
    – John Eason
    Aug 24, 2022 at 10:32
  • $\begingroup$ Yeah, I guessed so. I figured that my gpu just wasnt good enough but I was hoping that there was some way to make it work. Thanks for the answers though! $\endgroup$
    – frostproto
    Aug 24, 2022 at 10:40


Browse other questions tagged .