1
$\begingroup$

So I have made a "master scene" with two different light setups. I have a collection in there with lights for lighting buildings and another collection for lighting characters.

I want to be able to link this light scene into files where I have my characters or buildings and turn on and off the light setups I need for the render. (I don't want to append the lights because I want my lights to be updated all the time in all character/buildings files I have them linked to in the future.)

However, when I link the light scene into my files, I am able to turn on/off visibility of the light objects in the viewport, but I am not able to turn off "rendered". It's greyed out.

screenshot with greyed out icons

How can I solve this problem? Do I need to make 2 different light files?

$\endgroup$

3 Answers 3

2
$\begingroup$

There are some override operations you need to carry out so that various properties can become editable.

Here is a more complete, terse answer, but basically...

First make the library override for the data block via the RMB for the object in the Outliner panel:

enter image description here

Start with the top of your hierarchy that has the link icon, and you may only need to operate on the top parent, as Hierarchy implies "all children".

In additions (more complex items) you may have to do a second operations to make overrides Editable, probably not in your case:

enter image description here

Also note that if you linked the scene instead of the master collection, nothing is editable. You'll either have to click on the link button to make it local:

enter image description here

or you can create a Linked copy of the scene, where you will be able to do your overrides.

enter image description here

$\endgroup$
3
  • $\begingroup$ Thanks for the answer. However, blender gives me an error message: "Could not create library override from data-block (OBLight_Back_Buildings), one of it´s parents is not overridable. (SCLights). "SCLights" may refer to the scene here, but I am not sure. None of my lights has a parent, so I´m a bit confused here why I get this error message. And if it refers to the scene itself this makes no sense to me, as the sole point of making an override, is to override individual objects of the linked scene. $\endgroup$
    – liese
    Aug 23, 2022 at 8:30
  • 1
    $\begingroup$ @liese -- So I think when you linked, you linked the Scene instead of the collections. I've added to my answer how to compensate for this (create an editable scene); hopefully solving your issue. $\endgroup$
    – james_t
    Aug 24, 2022 at 17:15
  • 1
    $\begingroup$ True, I linked the whole scene. I got it to work now, by linking specific collections I need. To not have specific linked collections show in render, I use the "exclude from viev layer"-tick in the outliner. Also important to still be able to touch the button "exclude from view layer" after linking is to turn off the tick "instance collection" when linking. $\endgroup$
    – liese
    Sep 5, 2022 at 9:26
1
$\begingroup$

I was able to solve my problem by not linking the whole scene into my new file, but instead linking the collection, in which my lights are.

Also it is quite important to have the tick at "instance collection" when linking it in.

After having the lights collection in my scene, I still can´t turn off the little photo button to exclude it from render, but intstead I use the tick called "exclude from view layer".

A workaround for beeing able to turn lights on and off individually, is to have them in collections individually (in the source file). Because the little tick only is available for collections.

$\endgroup$
0
$\begingroup$

One solution is to play with lightgroups from Blender-3.2 and Cycle Engine (eevee doesn't support lightgroups) Ok, imagine having 2 files, the Master and the Slave.

  • Master will contains your lights and defines some lightgroups
  • Slave will link and use lights from Master according to your needs and will define lightgroups too

1. Master

- modify Scene Pty:
    > Passes:
        > Light Groups
            create 2 
            + 'Buildings'
            + 'Characters'

- add Light.000 and edit:
    > Object Property
        > Shading
            > Light Group
              select 'Buildings'
    > Object Data Pty (Light Icon)
      set some color

- add Light.001 and edit:
    > Object Property
        > Shading
            > Light Group
              select 'Characters'

    > Object Data Pty (Light Icon)
      set some other color

2. Slave

File -> Link your 'Character' lights from Master, then:

> Scene Pty:
    > Passes:
        > Light Groups
          create 1 
          + 'Characters' (!! SAME NAME !!!)
  • render the scene
  • Compositing:
    > Render layers Node:
      link the 'Combined_Characters' slot to Composite 'Image' slot.

Some pictures:

1. Master 3D View with 2 Lightgroups: Master 3D View with 2 Lightgroups

2. Slave 3D View with One Lightgroup and linked lights: Slave 3D View with one Lightgroup with the SAME NAME

3. Slave Composite View using Lightgroup 'Characters': Slave Composite View using Lightgroup 'Characters'

That's all folk!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .