1
$\begingroup$

just gave it a try the last days but maybe I'm not using correct keywords to solve my issue. Hopefully you can help me.

Just created some isometric cubes with Blender (3.0) and rendered each of them. Afterwards I put those rendered images next to each other in different program (e.g. Tiled, GIMP, ...) but unfortunately the transitions between those cubes are not smooth. Any idea how I can get rid of those "border" lines so it is not possible to see when a cube ends and the next once starts?

Played around a little bit with position of Light (Sun) but it doesn't solve my problem or at least I'm not able to find proper position.

enter image description here

In general I did nothing special just set up a cube change camera rotation (X=60° | Z=45°). You may can check attached blend file. Just render the cubes on your own and place it according to isometric rules. Might also help to make used of Tiled to place tiles.

$\endgroup$
5
  • 1
    $\begingroup$ It's unclear how you end up with this problem. Please edit the question and add more detail. What exact steps should someone take to get this problem? Or you could share a .blend file with the problem (Here ). The way I see it, you should just make the 3d objects more precise and snap them to each other so they don't have any gaps in 3d. $\endgroup$ Commented Aug 22, 2022 at 11:09
  • $\begingroup$ As @MartynasŽiemys mentions, some more detail would be interesting. If I create some cubes with let's say a cube length of 2 m and put them 2 m apart on one axis, there is no visible seam. What did you exactly do to get this result? $\endgroup$ Commented Aug 22, 2022 at 11:26
  • $\begingroup$ Oh wait a minute, those cubes are not lying next to each other in the scene and rendered together? Reading the question again I get the feeling you rendered them separately and put them together in the compositor...? I guess the problem them is antialiasing around the edges. $\endgroup$ Commented Aug 22, 2022 at 11:29
  • $\begingroup$ @Gordon, sorry if it wasn't clear enough. Yes I rendered each type of cube and put them together in separate program like Tiled or GIMP. Just added blend file, so you might can check on your own with same cubes. Based on rules of isometric view (as far as I understand them) the cubes are always placed at half of the other cube to look like they are in same row. Let's say first cube is 64px width and placed at 0|0 (X|Y) the next cube should be placed at X=32 and Y=16 to be in line with the first one. $\endgroup$
    – Psynox
    Commented Aug 22, 2022 at 11:35
  • 1
    $\begingroup$ No need to check the file, your isometric view rules are not the problem or how you place the cubes. It's a matter of antialiasing. $\endgroup$ Commented Aug 22, 2022 at 11:42

1 Answer 1

3
$\begingroup$

The problem you have here is the antialiasing which is controlled through the Filter Size setting under Render Properties > Film (in Eevee which you are using, in Cycles it's Pixel Filter > Width). By default this value is 1.5 pixels, which creates a smooth but not too blurry edge.

filter size

This is usually fine for rendering but creates problems when you want to overlay transparent images. The edges are now semi-transparent and no longer completely opaque which becomes visible for example when you are overlaying a shadowed side over a bright side or vice versa.

To get rid of these semi-transparent edges, you can set the Filter Size to 0 (or Width to 0.01 in Cycles). This way there will be no antialiasing. To see the difference, here is a comparison of the Alpha Channels, left is 1.5, right is 0. Wherever the pixels are not black (fully transparent) or white (fully opaque) the cube will be showing what's lying underneath:

alpha channels

This becomes visible when you place over a colored background for example. Of course that's usually what you want to make the edges appear smoother and more blended into the background:

color overlay

But it becomes a problem when you overlay those cube images with each other, then of course the underlying cube shows through and reveals that there are two objects instead of one:

cube overlay

The only problem you will now have when you disable antialiasing by setting the Filter Size to 0 is that the edges - not only the ones between object and transparency, but also within the object in textures etc. - will no longer be smoothed and might look worse than before. But this always depends on what you render and how your materials/textures look like.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .