2
$\begingroup$

When rendering an animation in Blender, before every frame the scene is calculated and updated. ("updating Scene, updating Images, updating Lights, loading HDRI...") In my case this takes a considerable amount of time -currently around 10s per frame, which is more then the the actual shading for each frame usually takes. (cycles, on a GTX 3090 with a very low sample count for non-final animations) It really adds up.

When I play the scene in the viewport in solid mode it performs close to realtime (around 30fps). When i change the 3d view to rendered it still manages to "start" rendering 2-3 frames per second in the viewport.

Is there a way to have that as well when exporting the animation? -at least for the rendering of non-final animations?

$\endgroup$

1 Answer 1

3
$\begingroup$

You should enable Persistent Data in Properties Editor > Render tab > Performance panel.

Blender Manual — Persistent Data

$\endgroup$
2
  • 1
    $\begingroup$ THANK YOU. That's so much better now. :) $\endgroup$
    – Patrick
    Aug 22, 2022 at 8:21
  • $\begingroup$ Glad I could help! $\endgroup$
    – L0Lock
    Aug 22, 2022 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .