6
$\begingroup$

I followed this video to make a plank with wood effect shader.

However, when cutting the plank at the end, I'm getting this result:

enter image description here

I'm losing the shader effect on the cut part. I may have missed something in the video but I can't see what.

How can I fix it?

$\endgroup$
5
  • $\begingroup$ Hello could you please share your file? blend-exchange.com $\endgroup$
    – moonboots
    Aug 18 at 8:44
  • $\begingroup$ @moonboots: and i thought you know everything....i am a bit disappointed that you need a blend file for that.... :D :D $\endgroup$
    – Chris
    Aug 18 at 8:52
  • $\begingroup$ oh ok, actually it will only happen if the plank object has the same material as the cut object, so he could just remove this material from the plank object, unless he needs it $\endgroup$
    – moonboots
    Aug 18 at 9:03
  • $\begingroup$ you see, I know everything $\endgroup$
    – moonboots
    Aug 18 at 9:03
  • $\begingroup$ For more information on how this behaves, see my comments under both answers ;) $\endgroup$ Aug 18 at 9:40

2 Answers 2

7
$\begingroup$

this is "normal", the cutting edge will get the material of the cutter object. If you want the cutting edge to have the same material, just give both objects the same material.

enter image description here

$\endgroup$
7
  • $\begingroup$ Thanks, it worked great! It seems the guy in the video did it another way, any idea how he did it ? $\endgroup$
    – DevonDahon
    Aug 18 at 8:58
  • $\begingroup$ Hi Devon, i am sorry, i didn't watch the video. But if you provide a time stamp of the video, where he does it, i will check it. $\endgroup$
    – Chris
    Aug 18 at 9:03
  • $\begingroup$ It's at the end $\endgroup$
    – DevonDahon
    Aug 18 at 9:06
  • 2
    $\begingroup$ @Chris +1 I agree the tutor cheated on this one, but maybe in a different way: if the modifier's Solver is switched to "Fast" instead of "Exact" (as it shows in the video) after the cut to disguise the error, than it wouldn't be necessary to add the material to the cutting object. Of course it could have been he just added the material, I just wanted to share the information that it could work without doing that :) But the "Fast" method won't work when they share materials, see moonboots' answer and my comment there. $\endgroup$ Aug 18 at 9:38
  • 1
    $\begingroup$ thanks for that info! I never realized that there is that (!) difference and i think that's a bit weird that it acts that way. $\endgroup$
    – Chris
    Aug 18 at 10:37
4
$\begingroup$

Actually it happens because if your original object (plank) shares a common material with the boolean object, this material will appear on the cut part. If you remove this material from the original object, this won't happen.

$\endgroup$
2
  • 1
    $\begingroup$ +1 Yeah, that's quite interesting. As I commented under @Chris answer, the cut would actually show the wood texture if the modifier was set to Solver > "Fast" instead of "Exact". But not if they share a material as you pointed out. The problem with your answer is, if the Solver is set to "Exact" (which it is by default), just removing the material won't work - it will still show the different material. And removing is only an option if you don't need it there, otherwise you can only make a duplicate of it. $\endgroup$ Aug 18 at 9:36
  • 1
    $\begingroup$ ok, I need to test that ;) $\endgroup$
    – moonboots
    Aug 18 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.