1
$\begingroup$

I know this question has been asked before but none of the answers solve my problem.

Here's my problem:

I have one (initially hidden through ticking off Camera in the visibility section) object that's affecting a different object with its color and material properties (it has some transmission, some color, some shadow, all of those things are affecting this other object).

enter image description here

Failed attempts:

  1. Alpha: If I use alpha to animate, I change the way in which it colors this separate object, which I don't want. I also change the properties of the material as it fades in which I don't want.

  2. Duplicate object: If I duplicate the object, have one with Camera turned off in the visibility window and one that's turned on (because I want to fade it in at a later point), and fade in the original (one without a check in the "Camera" visibility section) using alpha and transmission while fading out the other object (one with a check in the "Camera" visibility section) using alpha and transmission, that's closer but there's still an issue.

The issue is that the duplicated object now interacts with the original object (making it darker) even after alpha = 0, and transmission = 0. I'd like it to be completely gone and have no effect on other objects at this point. If after both alpha and transmission, I animate an abrupt tick-off of "Camera" in the visibility section, that will be undesirable, I don't want an abrupt shift like that.

  1. Transparent BSDF + Mix shader: If I create a mix shader, and connect a transparent BSDF to the other connector, as well as the original material, and try to fade in the original material with just one object, again this removes the effect the material has on other objects when it's fully transparent. The other issue is that the object is much brighter halfway through the mixing for some reason (as though you used Add or Multiply or something) which is undesirable.

Therefore, it would be MUCH easier, if there was simply a slider to control the "Camera" visibility of an object.

I would prefer not to use view layers and multiple render times as this would be a high resolution render of an animation that would cost me cloud compute.

$\endgroup$

1 Answer 1

1
$\begingroup$

Please correct me if I'm wrong, but if I understood the question correctly you want something like the option Ray Visibility > Camera instead of being switched on/off to gradually fade in/out. Maybe the Transparent BSDF and Mix Shader idea isn't that bad. Try the following:

As a mix factor between the normal object's material and the Transparent BSDF use the Light Path > Is Camera Ray node. This way the object affects others in the scene but doesn't show in camera. The Is Camera Ray value you can multiply by 0 with a Math node, then animate the multiplier from 0 to 1. This way the object fades out in camera view.

light path multiplier

This is an example of the result I'm getting with this setup. Nothing getting much brighter inbetween, as you mention in the question. However this might be dependent on the original material you're using. But I guess in your setup, where the object gets really transparent, this could be a reason while in this setup it only gets transparent for the camera.

camera fade

$\endgroup$
11
  • $\begingroup$ Absolutely beautiful! I honestly did not think one could get this close. Thank you so so much! I think the only thing missing for me is that I do have a light inside of the original object (which has some transmission and a lot of roughness). I noticed that while fading in the object using your method, the light inside of it is visible as though there was no roughness on the original object. I wish the roughness effect of the light was retained. Do you know if it's possible to use Light Paths to do that? $\endgroup$
    – Hmm
    Commented Aug 16, 2022 at 20:35
  • $\begingroup$ I think I can get around this by fading in the light after the object has faded in but was curious if that roughness effect could be retained. $\endgroup$
    – Hmm
    Commented Aug 16, 2022 at 20:36
  • $\begingroup$ Hm now I'm faced with a different problem entirely. This looks perfect in the viewport, but when I render as soon as it starts fading in from the transparent bsdf, the object is completely black and then fades to the original material. How did you manage to render it? $\endgroup$
    – Hmm
    Commented Aug 17, 2022 at 12:29
  • $\begingroup$ @Hmm I simply rendered it... maybe I should have asked this earlier since you don't mention it in the question: are you trying to render in Cycles or Eevee? I did this in Cycles and to be honest, I think Eevee isn't very great when it comes to transmissive materials, so maybe fading transparency might be even more of a problem...? $\endgroup$ Commented Aug 17, 2022 at 12:34
  • $\begingroup$ Ah okay... I'm not sure what's wrong in this case. I'm using Cycles, blender 3.2. I'm using a value of 1 on the Multiply with transparency node at the bottom. As soon as it's under one (so something like 0.8 or something), it goes completely black $\endgroup$
    – Hmm
    Commented Aug 17, 2022 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .