0
$\begingroup$

The image (as attached below) is a Cycles render (not viewport render) that I tried to see what was going on with the glass in my project. In rendered viewport mode, the glass is completely invisible.

As time goes on, the render renders less and less of the glass - in sharp lines (as emphasized by the pink lines). I don't know what's going on.

The separation between black area and non-black area progressively moves upward as the image renders.

Steps I've tried:

  • Changing the lighting to highlight the glass more.
  • Appending the collection to a separate file.
  • Turning up Transparent light bounces from 8 to 56.
  • Turning up ALL bounces to 56.
  • Turning on (and off) Simplify.
  • Changing the camera angle.
  • Appending everything from one file to another.
  • Unhiding all objects.

None of these changes have made any impact whatsoever thusfar and I have no idea what the issue is. This is the second time I've had an issue similar to this, on two separate versions of Blender (2.something, 3.1)

As for the material, here is what my node group looks like: (Keep in mind my UI is just purple, there are no drivers. Also, the Texture Coordinate nodes are both being used as UV outputs.) Glass material node group

And here are the steps I've taken to fix this:

  • Removing the Normal Map.
  • Removing the Glass BSDF.
  • Replacing the material with the default Principled BSDF (THIS DID WORK, but doesn't really help)
    • Changing the default Principled BSDF Roughness to 0.0 and Transmission to 1.0 (this also worked, but still doesn't really help)
  • Replacing the Specular input with 1.0 and Specular Tint with 0.0 (and 1.0, neither worked)
$\endgroup$

1 Answer 1

1
$\begingroup$

IOR was set to 0.0. Setting all IOR values to 0.05 fixes the issue. This seems like a bug.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .