6
$\begingroup$

I've been trying to bake a texture to vertex colors, with no results. The same procedure has been attempted with 3.2.2, 3.1.2 and 2.93.110 LTS.

I suspect that the reason is Cycles rendering not working properly.

Here'r the details shown under 3.2.2

  • Create a new project
  • Import the mesh as .obj
  • Assign an Image texture to the Base Color in the Material properties
  • Change viewport shading to Material preview and certify that the texture is displayed
  • In the Object Data properties add a Color Attribute as Vertex+Color
  • In the Render properties change render engine to Cycles
  • In the Render properties expand the Bake section and set Target as Color Attributes
  • Click Bake
  • Change viewport shading to solid mode and certify that the vertex colors have not been modified

Why I suspect a problem with Cycles? because if I open the Shading tab and check the Material Output of the selected material it defaults to "All".

enter image description here

If I switch to Cycles the output becomes all black.

enter image description here

Notes:

  • Under previous versions instead of black I have a purple color. The texture format is not responsible. I tried with .png, .jpg and .bmp
  • All other setting are the default installation, I have an Nvidia 1070 with latest drivers 516.94

Anyone can suggest a different workflow and/or confirm it's related to Cycles output? Thanks

$\endgroup$
1
  • $\begingroup$ Could you try to switch to CPU rendering, there is a chance it is some GPU bug (if a bug report it on Bug Tracker, because here it will be closed). And thank you, I missed this feature (Active Color Attribute) I didn't know it is possible already from 2.93 :) $\endgroup$
    – vklidu
    Aug 14, 2022 at 9:43

3 Answers 3

7
$\begingroup$

Works for me in 3.3.0 like that ... Create a new Color Attribute ... the same can be set under Attribute panel as well. enter image description here

enter image description here

Set Output > Target > Active Color Attribute (I used bake type Emit since I plugged image directly to output). enter image description here

Select Attribute node and Bake. enter image description here

enter image description here

Switch All to Cycles works the same for me.
Rendered with CPU (my GPU - ATI Radeon HD 5750 is not supported anymore).

$\endgroup$
1
$\begingroup$

Ok I found the reason why I didn't see the vertex colors, basically when switching the viewport shading to solid the color defaults to material, and it must be explicity set to "Attribute". Doing so displays the vertex colours. Sadly I can't find a way to export the baked colors to Unreal, but that's another story.

$\endgroup$
1
  • $\begingroup$ +1 Great you found solution :) I could mentioned that, I just didn't think it comes from this direction :) $\endgroup$
    – vklidu
    Aug 15, 2022 at 6:03
0
$\begingroup$

The way to export baked colours to Unreal Engine is simple, just export in FBX format, then on UE import window you need to select Replace at Vertex Color Import option. Only one colour attribute slot works in Unreal currently I see, so you need to clear all other colour attributes before exporting and it works. I made a kind of tutorial video about this workflow yesterday, I needed baked vertex colours for Unreal.

Here is the link to video:

Blender 3.4 Bake UV to Vertex Color - Bake Mixed RGB Diffuse to Vertex Color - UE test

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .