2
$\begingroup$

Looking to see how I can change workspace without it automatically forcing edit mode.

I'm someone that uses this function a whole lot, so this small niggly in your opinion, is a big annoying burden. It breaks the workflow.

I had a small work around for a bitty where when I changed workspace, I had a timer on a script where it would change edit mode to object mode. (but this method fails now)

https://www.youtube.com/watch?v=lYjPPjrkzUg

More description: Only does it when an object is in the scene (regardless if selected or not) and my pie menu is only calling: bpy.context.window_manager.windows[0].workspace = bpy.data.workspaces['Rigging']

I'll give ya a hug if you can help me out xD

$\endgroup$
6
  • $\begingroup$ Not sure what you mean? Changing workspace doesn't automatically switch to edit mode here. If a particular workspace has a 3D view in it, switching to it will mirror the 3D view mode that you'd selected in the previous workspace. $\endgroup$
    – John Eason
    Commented Aug 13, 2022 at 9:23
  • $\begingroup$ Uploading video, so you can 100% see the problem $\endgroup$ Commented Aug 13, 2022 at 9:36
  • $\begingroup$ I'm working on a clunky way. Unhiding an empty, selecting it. then switching workspace, deselecting empty and then hiding. This seems to work... bit over kill tbh! $\endgroup$ Commented Aug 13, 2022 at 9:42
  • $\begingroup$ Ah ok. I've no experience of that way of working here. Maybe someone else can help now that we can see a video. $\endgroup$
    – John Eason
    Commented Aug 13, 2022 at 9:46
  • $\begingroup$ @JohnEason are you sure? The Modeling and UV Editing workspaces always switch to Edit mode. Heading back to the Layout workspace always switches to Object mode (when you were in Modeling or UV Editing). But switching between workspaces Layout and Shading keeps the mode. And the Texture Paint workspace always switches to Texture Paint mode. But I don't know how this magic works. $\endgroup$
    – Blunder
    Commented Aug 13, 2022 at 10:53

1 Answer 1

7
$\begingroup$

You can set it in the "Active Tool and Workplace settings" panel:

Active Tool and Workplace settings

$\endgroup$
1
  • $\begingroup$ Thank you so much! This has worked! $\endgroup$ Commented Aug 13, 2022 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .