1
$\begingroup$

I'm loading scenes via logic.getBlendFileList and that's fine, I can access objects in it, set sensors and properties, and wire them with python modules. But I can't seem to access their animations: When I create an action actuator and select an animation (this object is an armature, appended in the scene, I can include the individual .blend file if needed) that this object has in the list menu, when I launch the game I get a rather laconic Failed to load action: MyAnimation.

On the other hand, I tried to create a "Property" actuator to toggle a boolean with a "pulse" sensor and it worked..?

Is it a limitation of logic.getBlendFileList, or are actions simply not available in python? Please excuse me if this is documented somewhere, in witch case can somebody please z-orient me to it?

$\endgroup$
  • 1
    $\begingroup$ did you load the action as well it seems to be considered separate see this DOC $\endgroup$ – Chebhou Mar 16 '15 at 14:55
  • $\begingroup$ Hey, this should be an answer, as it actually solved my problem; Thanks! $\endgroup$ – yPhil Mar 16 '15 at 19:12
  • $\begingroup$ But it does not work for complex actions ;( $\endgroup$ – yPhil Mar 19 '15 at 3:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.