2
$\begingroup$

I'm making a glass ring in Blender and am running into a very persistent problem with very dark shadows inside the ring. I am working with the Cycles render engine, as in Eevee the glass just appears gray.
You can view my file here

I have researched this on fora extensively and have already tried the following:

  • Increase max bounces of Light Paths in render properties, this didn't help (also see screenshots for settings)
  • Mix glass material with a transparant shader. This just makes the object 50% opaque it seems, which is not what I'm trying to achieve
  • Play around with the brightness of the lights
  • Reflective and retractive caustics are checked
  • Add a mesh light source instead of area light, this didn't help either.

Does anybody have any other ideas? You would be of enormous help!

Ring using mix shader with Glass BSDF and Transparent BSDF

Ring using Principled BSDF material

image 1: Ring using mix shader with Glass BSDF and Transparent BSDF

image 2: Ring using Principled BSDF material

EDIT: Based on some first insights (THANK YOU!) I have now set a world texture, but still try to get rid of the excessive reflection of this world. I am looking to make the ring see-through like glass, though still distorting the background (blue circles on white in the back) as well.

$\endgroup$
9
  • $\begingroup$ Well, how did you mix the Glass BSDF and Transparent BSDF? A screenshot of that setup would have been interesting instead of seeing the same material twice. If you simply used a mix factor of 0.5, than it's not just looking like it was set to 50% opacity, it is exactly what you have done... $\endgroup$ Commented Aug 11, 2022 at 11:31
  • 2
    $\begingroup$ Could you please highlight the dark shadows? If you're talking about the grey areas, it is just the world reflecting on your object, you need to plug a Texture > Environment Texture node into the Background of your World and upload an HDRI in order to have something else than your grey background $\endgroup$
    – moonboots
    Commented Aug 11, 2022 at 11:33
  • $\begingroup$ @moonboots That's what I suspect, too. Nevertheless there are things how you can improve the look of glass in Blender ;) $\endgroup$ Commented Aug 11, 2022 at 11:38
  • $\begingroup$ @GordonBrinkmann I added a screenshot that shows my settings for this. Thanks for your help! $\endgroup$
    – andreav
    Commented Aug 11, 2022 at 11:38
  • $\begingroup$ @moonboots I will try that! Thanks a lot! $\endgroup$
    – andreav
    Commented Aug 11, 2022 at 11:38

2 Answers 2

3
$\begingroup$

Your object is just reflecting the world, which is grey for the moment, if you want to quickly test an HDRI, open the Viewport Shading panel, deactivate the Scene World option and choose an HDRI. If you want to render you'll need to plug an Environment Texture into the Background of your world material though.

enter image description here

$\endgroup$
8
  • $\begingroup$ Thanks a lot! I added a white studio environemtn texture. Now however it reflects a white studio; while I want the glass to be see-through and not reflect any environment at all – though I am looking for it to distort the blue and white background, so setting the IOR closer to 1 doesn't do the trick. $\endgroup$
    – andreav
    Commented Aug 11, 2022 at 12:00
  • $\begingroup$ @andreav If you don't want the white studio to be reflected, you have to mix two Background shaders together, the first one is the white studio, the second is simply black. As a mix factor take the Light Path node and use the Is Glossy Ray output. $\endgroup$ Commented Aug 11, 2022 at 12:26
  • $\begingroup$ @adreav glass reflects by definition, if you don't want to see any background and see the white and blue image instead, you should use it as an HDRI, or project it on planes all around your object (or on a sphere, which is the same as using an HDRI) $\endgroup$
    – moonboots
    Commented Aug 11, 2022 at 12:42
  • $\begingroup$ @moonboots Although I know what you mean, projecting image on sphereusing an HDRI ;) $\endgroup$ Commented Aug 11, 2022 at 12:51
  • $\begingroup$ what do you mean? if you keep the UV sphere default unwrap and use an HDRI as material it will give the same result as a world HDRI, except you can zoom on the image, yes ok in that way it is not the same $\endgroup$
    – moonboots
    Commented Aug 11, 2022 at 12:56
0
$\begingroup$

try checking the Transparent Glass box in the "Film" section.

Transparent glass

$\endgroup$
2
  • $\begingroup$ Sadly didn't work. :-( $\endgroup$
    – andreav
    Commented Aug 11, 2022 at 18:36
  • $\begingroup$ Have you tried working with the IOR setting in the glass Node? $\endgroup$ Commented Aug 11, 2022 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .