2
$\begingroup$

I'm on blender 3.2.2 and I'd like to use SheepIt and/or Google Colab to support my render.

The scene uses Cycles @ 2048 samples, no de-noise, output PNG without compression. The main features of the scene are a principled volume shader for the fog, a spotlight from behind and an emitting plane from the front in order to have just a little bit of lighting for the foreground.

When I render on my Desktop (RTX 3080 (Laptop)), I start the render process from inside blender (GUI). The result is as follows:

enter image description here

I send the project to SheepIt and it was a disaster, but that is a different story... Anyway, the frames were rendered as follows:

https://youtu.be/bA8sypsqglE

One can see that SheepIt required me to tile the rendering in order to get decent render times. Firstly, I belived that the tiling would lead to this unexpected result, but then I tested a render on my RTX 3080 Laptop from the command line with the command

blender -b $filename -noaudio -E 'CYCLES' -o "G:\wolf_spot_" -s 157 -e 158 -a -- --cycles-device CUDA

and it led to this:

enter image description here

Obviously, the bad render result from SheepIt was not due to the tiling, but I suppose, because rendering there is also via command line and something is going on, when its done this way.

The resulting question is, what I can do (either in my .blend file or in the command line) so that I get the same result as by rendering in the blender application GUI?

An additional information:

I have a slightly different .blend file of the same scene, which uses a volume scatter node instead of the principled volume. Also the lighting is a little bit different. When I render this via command line on Google Colab (NVIDIA P100 GPU), it looks like this:

enter image description here

So this command line render is just working as expected...

$\endgroup$

1 Answer 1

1
$\begingroup$

It's not GUI/CLI that is causing the problem, but it is CUDA/OPTIX...

In Blender, I have set up OPTIX as render device. When I change it to CUDA, I get the same result as my render on the CLI with the "--cycles-device CUDA" option.

Vice versa, if I change "--cycles-device CUDA" to "--cycles-device OPTIX" in the command line, then I get the good result that I'm looking for...

I thought that CUDA and OPTIX should yield the same results, with maybe very slight differences....

What are your thoughts? Is this a bug in the CYCLES renderer?

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .