3
$\begingroup$

I am using windows 7 64-bit, freshly installed. I installed Blender 2.73a but after installation, when I open blender it crashes (Blender has stopped working), but Blender 2.68 works perfectly fine.

A similar question has been asked before but the solutions haven't helped.

$\endgroup$
4
  • 1
    $\begingroup$ In your question please be explicit about which solutions you have tried, and what kind of graphics card you have. $\endgroup$ – zeffii Mar 15 '15 at 11:45
  • $\begingroup$ Do any of the 2.7 series work on your machine? $\endgroup$ – VRM Mar 15 '15 at 18:21
  • $\begingroup$ im using an geforce 840m in my laptop i7 with 8 gb of ram windows 7 professional Edition, version that worked(windows 7): 2.68 and 2.70 only all the other version won't even start up even 2.73. it shows (blender has stopped working) Note:I was using 2.73 before when i was in windows 8.1, last month i switched to windows 7 professional since then the most recent version i can used is only the 2.70a version.. Thank you everyone $\endgroup$ – Allen Mar 20 '15 at 14:18
  • $\begingroup$ i fix it myself. i followed a solution similar to my problem, by copying the python34 folder to (2.73/python) it worked, but, everytime i press shift z (rendered view)it crashes. I guess i'll just have to use 2.70 until someone has fix this issues in later versions, by the way thanks everyone. $\endgroup$ – Allen Mar 21 '15 at 14:23
5
$\begingroup$

If the problem is related to having a PYTHONPATH environment variable set, you can do the following so you don't have to modify your PYTHONPATH variable. I am running 2.75a and this fixed my problem.

  1. Make a batch file somewhere like your desktop
    • To do so, create a blank .txt document and name it blender.bat (MAKE SURE THE EXTENSION IS .bat and not .txt)
  2. Edit blender.bat and add the text below

    set PYTHONPATH=""
    cd C:\Program Files\Blender Foundation\Blender\
    start blender.exe
    
  3. Your blender path may be different, so make sure you find the correct path

  4. run blender.bat

This will temporarily set the PYTHONPATH to "" (nothing) during your blender session but is restored after you close.

$\endgroup$
2
  • $\begingroup$ This suggestion resolved the issue for me on Windows 10 x64 with Blender 2.78a $\endgroup$ – Amr Nov 30 '16 at 4:08
  • $\begingroup$ Way to late but, it didn't helped. I'm getting "C++ Runtime Error" $\endgroup$ – Naman Jun 21 '17 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.