1
$\begingroup$

I want to install Blender on an old XP machine. The computer has Windows XP sp3 and 3GB RAM.

I read about options and Blender 2.72b was suggested as a nice stable version that works on XP. If somebody has a better suggestion, I am open to try other versions.

Install completed and said it was "Finished", but when I try to run the program, a blank black application window with the Blender name/icon in the title bar appears and I get a Windows popup error:

blender-app.exe - Application Error
The application failed to initialize properly (0xc0150002). Click on OK to terminate the application.
OK

In trying to identify the 0xc0150002 error, it seems to be related to Microsoft Visual C++, so I installed a version that was older than 2014 Blender 2.72b. I installed Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219; but still get the same error.

Any help would be appreciated.

I did see the question below StackExchange question: https://blender.stackexchange.com/questions/64693/install-blender-on-windows-xp?rq=1

There they suggest using the .zip version instead of the .exe install. I tried both and both have the same error message; so it is not the installer (which as mentioned, installed with no errors, ending on the "Finished" screen).

Likewise, one forum said trying a different version solved their problem, so I tried installing Blender 2.68a, which was also suggested as an old very solid version, and I got the same error. I also tried installing it on two different XP machines, both with sp3. Same error.

The below question on the Blender forum makes me think that seeing the system requirements for these old installs might be helpful. Does anyone know if those are archived somewhere?

https://developer.blender.org/T40718

$\endgroup$
2
  • $\begingroup$ fwiw, i run the latest blender version 3.2 with windows 7 using this tutorial youtu.be/n3RGmnRTig8 not sure if it works for XP but do this at your own risk, it could mess up your DLL files XD $\endgroup$
    – Harry McKenzie
    Commented Aug 9, 2022 at 4:49
  • $\begingroup$ @HarryMcKenzie What do I do if I am not getting any error message except the one I listed above? How do I know what DLL it is wanting? Do you know if there is a log file somewhere that I need to find? All I have to go by is that one Microsoft error code "0xc0150002". $\endgroup$
    – Thomas
    Commented Aug 10, 2022 at 18:25

0

You must log in to answer this question.

Browse other questions tagged .