2
$\begingroup$

I am in the modelling view, and I would like to render this view. I don't want to do anything else or switch to something, I would simply like to render what I see here:

enter image description here

However, when I press Render -> Render Image, it renders something else instead. The angle is different. I guess Blender uses a keyframe in my animation. But I don't want that. I would like to render my current view instead.

enter image description here

I was thinking "Ok, perhaps Render Image always renders something specific, and there might yet be another command like "Render current view", but I don't find it.

Thank you if you can tell me how I can render what I see.

Edit: If I press Viewport Render Image as suggested, I see this, and it's not changing. What am I missing?

enter image description here

$\endgroup$
2
  • $\begingroup$ Are you using cycles or EEVEE render engine? $\endgroup$
    – Emir
    Aug 7 at 13:59
  • $\begingroup$ On the right side, I click the icon under the wrench tools, it says "Scene". There it says Render Engine: Cycles. $\endgroup$
    – tmighty
    Aug 7 at 16:28

1 Answer 1

2
$\begingroup$

If you do a Render > Render Image, it will render the camera view, so the render will depend on your camera position and focal. You can move your camera to your current view though, with a CtrlAlt0 but the camera needs to have the same lens focal as your viewport view if you want no difference.

Or you can go into View > Viewport Render Image instead and it will render the exact same thing as your view (it doesn't work in Cycles + Rendered viewport shading though):

enter image description here

From your current file, switch to Object mode, enable visibility and selectability of the collection called Scene in the Outliner, select Camera_2, in the Properties panel > Camera > Lens > Focal Length, you have a keyframe with the focal at 55 at frame 72, remove this keyframe and set it to 50 (or set the view focal to 55 as well). Now choose the view you want and press CtrlAlt0 to make the camera view match the view, or press 0, in the N panel > View > View Lock, enable Lock Camera to View and move your camera until you have the view you want.

enter image description here

$\endgroup$
12
  • $\begingroup$ Super, thank you very much! $\endgroup$
    – tmighty
    Aug 7 at 13:09
  • $\begingroup$ Unfortunately my render is empty, and it's not changing. I have added this info to my post, also a screenshot. $\endgroup$
    – tmighty
    Aug 7 at 13:11
  • $\begingroup$ could you please pack your image (File > External Data > Pack Resources) and share your file? blend-exchange.com Also uncheck the solve button so that it's not marked as solved $\endgroup$
    – moonboots
    Aug 7 at 13:13
  • $\begingroup$ OK my bad, View Render Image doesn't work in Cycles in Rendered viewport shading, so I guess you need to use the first solution (i.e. move your camera to your current view) $\endgroup$
    – moonboots
    Aug 7 at 15:06
  • $\begingroup$ For some reason, it won't work for me. I click "Camera_2", then "N", then "View", then Focal length: 200, then Ctrl+Alt+0, then Render Image, but nothing changed. $\endgroup$
    – tmighty
    Aug 7 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.