0
$\begingroup$

I have set "move" to snap by increment. It works perfectly with a few objects. But the moment I start to add many objects together, the snap is not aligned anymore to the grid. I have checked that the origins of all the objects are correct (as they are all copies of the originals that snap well when moved individually). I have found ways to solve this by snapping to vertices, but it would really help my workflow if I could use snap to increment all the time.

I tried by locking movement to a single axis as well as making the amount of objects an odd or even number. I also tried deleting everything and starting fresh from objects that are clean and snap well individually.

$\endgroup$
5
  • 2
    $\begingroup$ Its probably because it's snapping the median origin of all objects you have selected, absolutely to the grid. Try pushing CTRL+SHIFT+TAB to change your snapping settings and Changing it from Center to Closest or Active and see if that helps. $\endgroup$
    – Jakemoyo
    Commented Aug 5, 2022 at 12:48
  • $\begingroup$ The option you mention exists for snap to vertices, edges etc. But not for snap to increments. $\endgroup$
    – Coldsun
    Commented Aug 5, 2022 at 13:12
  • $\begingroup$ Hm, I guess you're right, I was just going from memory there. $\endgroup$
    – Jakemoyo
    Commented Aug 5, 2022 at 13:35
  • 2
    $\begingroup$ What you could do is parent all the objects you want to move to one object, then Shift+S > Selection to Grid that one object, move it how you want, then unparent them. That or create an empty and parent the objects to it, then move that on the grid. $\endgroup$
    – Jakemoyo
    Commented Aug 5, 2022 at 13:37
  • 1
    $\begingroup$ That works. Thank you! $\endgroup$
    – Coldsun
    Commented Aug 5, 2022 at 16:30

0

You must log in to answer this question.

Browse other questions tagged .