I've imported an .obj file but can't see the object. It shows up listed in the Outliner, but I can't see anything. When I press NumPad ., I see this shown in the screenshot instead, which is still nothing. I've also tried using N and Shift+C to try to see it but still nothing. I try to resize, change the mode to see if I can see vertices, like when I import something that is too big or small, but this is all I see. It's not a model I made but I can see it in Microsoft 3D viewer so I know something is in the imported object file.

enter image description here

  • $\begingroup$ Yes I had this problem too and it seems like a bug that it does not load and immediately you see an empty mesh object in the Outliner. I know it because when i tried closing blender and opening it again and doing the same import again then it was loading for a while before importing it and it worked. But still possible duplicate question to blender.stackexchange.com/questions/31766/… $\endgroup$ Aug 5, 2022 at 4:55
  • $\begingroup$ That's not it. I've opened and closed it several times, I adusted the camera, viewpoint an clipping now too and still nothing. I've also just left it to load for a while and still nothing. $\endgroup$ Aug 5, 2022 at 5:12
  • $\begingroup$ can you share a link of the obj file? $\endgroup$ Aug 5, 2022 at 5:20
  • $\begingroup$ Sure. This is the file. If you can get it to load/see it and it looks all messed up and stretched, that's normal. But other files that have been like this I've been able to import and see. drive.google.com/file/d/1c0TbMn8h5rROd9aJoKbXce6opxnNmbrM/… $\endgroup$ Aug 5, 2022 at 5:29

1 Answer 1


Your object is super huge with dimension of up to 20km

1 Click the imported object in the Outliner
2 Press N and change scale to 0.001
3 Press NumPad .

enter image description here

  • $\begingroup$ Yep that sure was it! I could have sworn that was the first thing I did, but it might not have been enough. Thanks for the help! $\endgroup$ Aug 5, 2022 at 6:00
  • $\begingroup$ yeah. the link that is also provided is usually the link they use to mark these questions as duplicates but the answer wasn't so clear about the size, so I added a more simple answer that the first step should definitely be to check the dimensions :D blender.stackexchange.com/a/271224/142292 $\endgroup$ Aug 5, 2022 at 6:06
  • $\begingroup$ @MushyNarwhal Usually selecting the object in the outliner and pressing Numpad '.' in viewport should center the view on the object - and maybe you even did that - but if you didn't scale the object smaller, with the default clipping end at 1000 m an object with a size of 23000 m remains invisible. Which also means, if for some reason you want to keep that size, you could adjust the viewport clipping values to e.g. start at 100 m and end at 100000 m. $\endgroup$ Aug 5, 2022 at 6:09
  • $\begingroup$ @HarryMcKenzie Haha yeah hopefully it helps someone else from looking like a goof like I did cause I didn't double check in the future! Lol $\endgroup$ Aug 5, 2022 at 6:18
  • $\begingroup$ @GordonBrinkmann Yeah I just thought I'd done that, but ended up having not. Even shrunk it appears oddly in the camera. I don't want it that big, but if there's ever some reason I need a huge model, I'll do that. Thanks for the tip! $\endgroup$ Aug 5, 2022 at 6:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .