2
$\begingroup$

In the Blender Game Engine, I used servo control to move a cube along the x axis when "W" was pressed. That worked fine, but when I used the exact same settings (except for direction, of course) to make it move on the negative x axis when "S" was pressed, it wouldn't move. I even tried changing the direction to the positive x, and that worked fine. But when I switched it back, it didn't work again. And I don't think that it is because of directional friction, because this same thing happens when it is on a different platform, or even in midair. Also, it works fine when I don't give it an x limit, but even if I give it a limit of 10000 it wont budge. And I really need that limit on it. Does anybody know why this is happening? Thanks!

$\endgroup$
  • 3
    $\begingroup$ you also has to set the limit force min to -10000 (the force will be negative for backward movement) $\endgroup$ – Chebhou Mar 14 '15 at 15:36
  • $\begingroup$ @Chebhou Add as answer so we get this off the kill list :D $\endgroup$ – VRM Mar 14 '15 at 16:05
  • $\begingroup$ My phrase... :D $\endgroup$ – Scalia Mar 14 '15 at 16:14
2
$\begingroup$

Since you are moving the Object in the negative direction ( -X ) you need to set the minimum limit instead of the maximum and it should be negative as the force applied on the object will be negative :

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.