0
$\begingroup$

This is an unfamiliar behavior but it may just be that I'm working differently than usual.

When I set an object's origin to the 3D Cursor and then move the cursor, the object's origin moves with it. My mirror modifiers then reflect that change. I don't remember this as being the way that it worked. Have I accidentally set origins to be locked to the cursor, or is that just the way that it's always been? I'm wanting to set the origin to a specific vertex on the object and have that origin stay relative to that vertex regardless of the object's position or orientation. I seem to remember an option to "Set Origin to Selected" but can't find that in 3.2.1

EDIT: On closer examination, it appears that the origin snaps back to the 3D cursor after being moved. It snaps once the object is selected again after the move. Snapping Origin

$\endgroup$
4
  • $\begingroup$ The menu "Object" >> "Set Origin" will allow you to adjust to where. But I'm not thinking of any way where an origin will then track the movement of the 3D Cursor. I assume you are in Object mode. $\endgroup$
    – james_t
    Commented Aug 3, 2022 at 18:16
  • $\begingroup$ Please see the edit above. $\endgroup$
    – TroyT
    Commented Aug 3, 2022 at 19:34
  • $\begingroup$ Not sure why it would cause the effect that you're seeing, but I assume you know that you have snapping turned on ? (Horseshoe-shaped icon in the centre of the top toolbar.) $\endgroup$
    – John Eason
    Commented Aug 3, 2022 at 20:34
  • $\begingroup$ Yes, but it happens whether snapping is on or off. $\endgroup$
    – TroyT
    Commented Aug 3, 2022 at 22:54

3 Answers 3

1
$\begingroup$

Solution is to Ctrl+A > Apply All Transforms

$\endgroup$
1
$\begingroup$

Maybe a little late, but your origin is following the cursor because in the "Transform Pivot Point" you have the "3D Cursor" option active.

$\endgroup$
-1
$\begingroup$

You go into Edit Mode, select the vertex you want to set as origin, hit ⇧ Shift + S and it will bring you a pop-up menu.

You will want to hit Cursor to Selected, now go back into Object Mode and right click. Go to Set Origin, and click Origin to 3d Cursor.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .