1
$\begingroup$

I made a cube and added a grease pencil stroke to create a line art of the cube. Now i turned the cube off in the renderd image to just render the grease pencil stroke lineart of the cube. No lineart is displayed at the rendered image. Can someone help me?enter image description here enter image description here

Solved: I have to bake the lineart.

$\endgroup$

2 Answers 2

1
$\begingroup$

If you don't want to bake the Line Art for various reasons, you could simply give the cube a Transparent BSDF set to full white as a material, this way it's invisible in the render but the lines still show. The other possibility would be to disable everything under Visibility > Ray Visibility in the cube's Object Properties.

  1. option: give the cube a material to make it invisible

material

  1. option: disable all Ray Visibility settings

ray visibility

$\endgroup$
1
$\begingroup$

Use a holdout shader:

enter image description here

The Holdout shader node is used to create a “hole” in the image with zero alpha transparency, which is useful for compositing (see Alpha Channel).

Source: Holdout — Blender Manual

$\endgroup$
2
  • 1
    $\begingroup$ This will hide everything behind the object as well, which can be intended, or not, or irrelevant for OP. $\endgroup$ Sep 12, 2023 at 19:34
  • $\begingroup$ Yes, in which case the other answer covers it all ;) $\endgroup$
    – Lauloque
    Sep 12, 2023 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .