1
$\begingroup$

I am working on a character and grooming the fur on them. Due to earlier issues with the particle mirror(even with perfectly mirrored guide hairs, the brush strokes were not mirroring), I groomed all the guide hairs on only one side of the mesh. When attempting to mirror, the guides would not mirror correctly and would have an incorrect orientation. This would make the left side's fur look fine while the right side looked patchy and off. The character and its origin point are perfectly centered on the x axis.

Pre mirrored guides

When manually mirroring using Control+M, the guides mirrored to the other side directly. The issue only occurred when using the mirror tool that would duplicate and flip on the X axis. The first image below this shows the correct mirror using Control+M, and the second shows a failed mirror using the mirror tool.

Correct mirror using Control+M

Failed mirror using the mirror tool

With the failed mirror guides, you can see significant aberrations in the fur on the right(left from camera view) pectoral and throughout the side of the face.

How would I solve this mirror issue? And, if it can't be solved, is it possible to copy the guide hairs and mirror using Control+M? I cannot copy the guides using Control+C+V so I was wondering if there was another method.

$\endgroup$

1 Answer 1

1
$\begingroup$

I had a similar problem recently. I did a bunch o operations, and don't know exactly what fixed it, but one of these might solve your problem.

  1. Go to Properties > Object Data Properties > Geometry Data, then clear sculpt mask data and clear custom split normals data, if your mesh has any.
  2. Press Alt + N in Edit Mode, and then recalculate normals outside. Also make sure your mesh has the correct orientation with Viewport Overlays > Face Orientation, it needs to look blue on the outside.
  3. If you have any shape keys on your mesh that could deform it in a way to make the geometry asymmetrical, make sure they are all set to 0 by clicking on the X button at the right bottom corner of the shape key list. Also try changing which shape key is selected while you are in Particle Edit Mode.
  4. Go to Outliner > Orphan Data, and then click the Purge button. I have a feeling Blender might be retaining data about previous particle systems somehow, and messing new ones. It is probably not the case, but might be worth trying.
  5. Make sure the particle systems come first in the modifier stack, particularly before any Deform modifier that could make the mesh asymmetrical.

If all of this fails, duplicate your particle system, go to Tool panel while in Particle Edit Mode, uncheck Preserve > Root Positions, select all particle hairs that you want to mirror, scale by -1 on the X axis to invert the hair direction, move the hairs to the other side of the mesh on the X axis, then enable preserve root positions again. Downside is that you now have to handle 2 particle systems separately, but they are at least correctly mirrored.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .