So, I've created a mesh in Houdini, and exported it to blender. The UV's look like how you would expect in a standard square layout, but get warped whenever you use anything else. Any idea why? All I want is for it to be uniform in size so I can throw on different sized images.

Using blender 3.2.0

.blend: https://drive.google.com/file/d/1k-2IOlBgNY8rQC0kUlDlP3G8VJnDbGcz/view?usp=sharing

normal square layout

image 1

warped layout

enter image description here

Object I'm trying to make it work on

enter image description here

Texture nodes


  • $\begingroup$ it's just a flat rectangular surface? why not unwrap it again? $\endgroup$ Jul 28, 2022 at 7:39
  • $\begingroup$ because I have to do it in Houdini. I'm trying to create a procedural thing and only render it in blender. I don't want to unwrap every time I make a small change in houdini $\endgroup$ Jul 28, 2022 at 7:41
  • $\begingroup$ i don't know much about houdini but it may be a compatibility issue? you could write a script that unwraps for you so whenever you import run the script something like bpy.ops.object.editmode_toggle() then bpy.ops.mesh.select_all(action='SELECT') then bpy.ops.uv.unwrap(method='ANGLE_BASED', margin=0.001) $\endgroup$ Jul 28, 2022 at 7:49
  • $\begingroup$ Well, UV's are standardised, so I really doubt it's a compatibility thing. Pretty sure there's just a setting somewhere that I don't know of. also, the same behaviour happens when unwrapping in blender $\endgroup$ Jul 28, 2022 at 8:12

1 Answer 1


You have some UV scaling in the nodes, so that texture 46% smaller than UV

enter image description here

Then you change Image with different aspect ratio, it is designed to be stretched. This is because UV's coordinates are written in percents, not in pixels. This allows to switch between resolution versions without having problems.

If you open the front view and press U ⇾ Project from view, It will give you the right aspect ratio according to the image in the shader.

  • $\begingroup$ that was just so I could see it. it's uniform in all vectors so it doesn't matter. If I set it to 1 the same thing happens $\endgroup$ Jul 28, 2022 at 9:15
  • $\begingroup$ can you share the file? blend-exchange.com $\endgroup$
    – Crantisz
    Jul 28, 2022 at 9:16
  • $\begingroup$ Blend exchange wont upload for some reason drive.google.com/file/d/1k-2IOlBgNY8rQC0kUlDlP3G8VJnDbGcz/… $\endgroup$ Jul 28, 2022 at 9:31
  • $\begingroup$ Location 0 and scale 1 gives me correct result. $\endgroup$
    – Crantisz
    Jul 28, 2022 at 9:40
  • $\begingroup$ no, it just looks like that. if you zoom out, it's actually stretched into a square. I'm trying to get it into the aspect ratio of the image $\endgroup$ Jul 28, 2022 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .