so I have this problem. I am rendering an animation. It has originally 740 frames at 30 fps, but I rendered just 100 to check if everything was alright.

It's not, when I put together the frames and export from Blender, the camera movement in the video is jaggy/glitchy/laggy. It doesn't happen in solid mode and I can't try that either in material or rendered mode since the fps in the viewport drops so big time I can't see the changes.

Originally there was an irradiance lightning/volume, but I deleted that thinking it was the problem. It was not, the problem persists and I dont know how to proceed.

There is also a problem where as the camera moves, there is some glitching of shadows on the TV shelf happening and I dont know why, I dont know what to do with it.

Can somebody help me please?

The video and the file is on this Google drive. The file has 1.8 gb so I cannot upload on Mediafire, hope its okay.


  • $\begingroup$ the file is too big. reduce it by going into File > Clean up. delete as much from the file as u can to create a simple reproducible setup. $\endgroup$ Jul 27, 2022 at 14:33
  • $\begingroup$ @HarryMcKenzie Okay I did all of that, all 6 options of clean-up data, deleted also all unused models in the scene, but it still happens. There is not much left for me to delete without affecting the scene. I also used a lot of ambient occlusion nodes in the shading, I deleted those too since they are not necessary, but nothing really changed when I am rendering 2500x2500 frames. Do you have any other idea what I can do the troubleshoot this? Thank you $\endgroup$
    – bastienjpg
    Aug 1, 2022 at 7:55
  • $\begingroup$ i downloaded the 1.7GB file but unfortunately my setup is too slow i can't render it sorry :( $\endgroup$ Aug 1, 2022 at 8:07
  • $\begingroup$ @HarryMcKenzie I cleaned up the folder and changed everything a lot, still doesnt work. I updated the files on the drive. Usually its okay to render just 60 frames to see if the problem persists. Do you have any other idea what could be the problem? I can also render the changes you made if you made any so you don't have to. I am so clueless $\endgroup$
    – bastienjpg
    Aug 1, 2022 at 19:43

1 Answer 1


Make sure if that you don't have a glass material with Screen Space Refractions turned on in the scene.

For some reason that is making the camera glitchy. My glass shader was made of Transparent + Diffuse (50% transparency) with ambient occlusion in the fac. The material had the SSR turned on. After turning it off, the scene works perfectly.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .