0
$\begingroup$

I have an image texture that's connected to a mixed RGB(Multiply mode) and then a bsdf And after the bake I only got the color and no textures, When I removed the mixed RGB it works again, Do I have to change the color of the texture instead?

$\endgroup$

1 Answer 1

0
$\begingroup$

It works with Mix RGB node also.

Make sure that before you press the bake button the image texture node you want to bake on is selected.

Check your node setup also, the Color Ramp input is feeded by the vector displacement output, while it should get the Fac or color output of the Magic Texture.

enter image description here

$\endgroup$
6
  • $\begingroup$ I have selected the texture that I need to bake but it still doesn't work, My mixRGB's factor is on max, maybe that's the cause? $\endgroup$
    – Yy_XRC
    Commented Jul 25, 2022 at 15:53
  • $\begingroup$ It should work even with the Fac at 1.0. Maybe you could upload your file? blend-exchange.com $\endgroup$ Commented Jul 25, 2022 at 16:01
  • $\begingroup$ Sorry for the late respond, Yeah sure, Here's the file <img src="https://blend-exchange.com/embedImage.png?bid=7PNYLpJo" /> $\endgroup$
    – Yy_XRC
    Commented Jul 28, 2022 at 8:01
  • $\begingroup$ I updated my answer. $\endgroup$ Commented Jul 28, 2022 at 11:10
  • $\begingroup$ Tried connecting the color ramp with the magic fac and the color, It still only print the color, No texture, Could be something to do with the depth I set, It's at 0, But I want the checker pattern, I might need to use a tons of math nodes. $\endgroup$
    – Yy_XRC
    Commented Jul 28, 2022 at 12:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .