54
$\begingroup$

The Blender UI elements are incredibly small by default on high resolution screens on Windows (15" UHD screen). I found the Preferences -> System -> DPI setting which can be set up to 144. This makes Blender usable, but still uncomfortable and difficult on the eyes. Is there a way to make the UI elements even larger?

$\endgroup$
1
  • 2
    $\begingroup$ under that there is Virtual pixel mode choose : Double $\endgroup$
    – Chebhou
    Mar 11, 2015 at 19:45

5 Answers 5

62
$\begingroup$

To make the UI elements even larger you can choose Double under the Virtual Pixel mode this option is in User_Preferences->system enter image description here

$\endgroup$
2
  • $\begingroup$ A combination of DPI and Double can really do the trick. My native DPI on my 4k 27" monitor is 164 dpi. I set virtual pixel mode to double and DPI: to half of 164, i.e. 82. So that 2 x 82 = 164. I wish you could go higher on DPI though. $\endgroup$
    – phorgan1
    Dec 28, 2016 at 0:17
  • 2
    $\begingroup$ This is obsolete by now ? $\endgroup$ Apr 28, 2018 at 13:45
33
$\begingroup$

Another thing that is very useful is to hold down Ctrl and the Middle Mouse Button to rescale various panels. This is the same for the 3D Viewport when zooming in or out to view a model. The Outliner Area is the only place I've found so far where this does not function yet.

enter image description here

By pressing the HOME key on your keyboard, you can reset the resized panels back to the original default size.

$\endgroup$
2
  • $\begingroup$ Neat trick. I can't figure out how to do this with the keypad on a Surface Book but I was able to do it with an Arc mouse by holding CTRL and "double-tap and holding" the scroll pad. Thanks. Maybe StackOverflow needs to add the ability to have multiple correct answers because both your answer and the answer from @Chebhou are two important pieces of the puzzle. $\endgroup$ Mar 3, 2016 at 3:39
  • $\begingroup$ THANK-YOU! i can now avoid going blind between 4k and 2k res ! :) $\endgroup$ May 16, 2019 at 21:58
15
$\begingroup$

Hover the cursor over one of the panels and hit Numpad + or Numpad - keys on the keyboard to change the size of the font and UI elements.

$\endgroup$
10
$\begingroup$

As of the latest version, the setting name has changed.
File > User Preferences
or CTRL ALT U

And the very first entry at the top:
Display: Scale
enter image description here

$\endgroup$
3
$\begingroup$

In version 2.8 this setting is now under Edit -> Preferences -> Interface -> Resolution Scale

Resolution Scale Setting Screenshot

$\endgroup$
1
  • $\begingroup$ It would be cool that blender takes the value of gsettings get org.gnome.desktop.interface text-scaling-factor be default, so one doesn't have to search the option with a magnifier. $\endgroup$ Jan 28 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.