8
$\begingroup$

This question already has an answer here:

When rendering a simple video in FullHD right now (one video track, one audio track), the encoding process takes about one second per frame. Let's say I'd like to render a 5-minute clip in 24fps:

5*60*24 = 7200 frames

1s per frame = 7200/60 = 120 minutes of rendering time.

It seems very slow to me. Is there a way to speed up this process? Mabye use different codec? Or maybe I should render to RAW file and then encode it using an external tool? Right now I'm using x.264 coded with default settings.

$\endgroup$

marked as duplicate by Shady Puck, Ray Mairlot, A Wild RolandiXor, David Sep 12 '16 at 22:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    $\begingroup$ You may want to use an actual video editing program that is designed for that type of work, the VSE will never be as good, and is just something that was added to Blender, as an afterthought. There is quite likely major optimization issues internally. $\endgroup$ – VRM Mar 11 '15 at 14:18
  • $\begingroup$ Try FFMpeg or other external encoder. $\endgroup$ – cegaton Mar 11 '15 at 14:24
  • $\begingroup$ You can see my detailed answer here that I have written for a similar question about speeding up VSE rendering: blender.stackexchange.com/a/44906/20611 $\endgroup$ – Isti115 Jan 13 '16 at 16:00
  • $\begingroup$ @NᴏᴠɪᴄᴇIɴDɪsɢᴜɪsᴇ I've actually found the VSE to be able to render a video edit quicker than something like Premiere. $\endgroup$ – Ray Mairlot Sep 12 '16 at 20:56
3
$\begingroup$

Using only colored effect strips and a track of music, I rendered 240 frames resulting in the following export times: H264 = 16 secs MP4 = 14 secs xvid = 13 secs

This tests only the encoding engine. I would also suggest checking the dimensions of the media you are editing with. Any scaling (which the VSE will do automatically) impacts on render time. Try to make this 1:1 with the scene dimensions. Further to the issue of scaling you may want to alter the AntiAliasing value in the scene properties as well. Default is 8 samples.

Finally, in User Prefs, increase the 'sequencer cache' value to maximise your memory usage. And check that you are using the Sound Output Device SDL, in the same panel.

$\endgroup$
  • $\begingroup$ Were those frames very similar? Was the source material encoded in h264? In my case, the source material was a speed-modeling video recorded at 1 fps so almost every frame was drastically different than the previous one. I also suppose that it was recoded in h264 but I don't have access to this file from here to check it for sure. The dimensions of the output were exactly the same as dimensions of the input, no scaling. The only addition was a watermark layer (again, the same dimensions) alpha overed over the entire video. Here is the final product: youtube.com/watch?v=PdRiQu09qQA $\endgroup$ – jubi Mar 18 '15 at 13:20
  • $\begingroup$ Yes I did not include video so that the compression engines were not stressed, I was just testing the speed of file writing. It could be that you are having issues with memory, you can also specify a frame buffer per strip in the VSE strip properties panel. Your video is relatively short, so this is odd. Did you apply a speed effect for the timelapse? BTW I really liked the video! $\endgroup$ – 3pointedit Mar 19 '15 at 3:26
  • 1
    $\begingroup$ You were absolutely right about scaling! I DID use scaling, while rendering the final video (from 2560x1440 to 1920x1080). When I set the final dimensions of the video to 2560x1440, the speedup is 2-fold, from 48 to 100 frames rendered per 30 seconds at the start of the video, $\endgroup$ – jubi Mar 24 '15 at 20:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.