I'm seeing a lot of posts with the new Hair curve, for creating hair. I found how to make thickness with geometry nodes but, I don't know how to add a profile to make the tip pointy, and tapered. Does anyone know how?


1 Answer 1


You can see it briefly in the official video. They use a Geometry Nodes modifier for the new Hair Curve object with a Float Curve node. It defines the thickness profile of the hair from the root to the tip.

The Map Range node is used to scale the root and tip values individually and to have them in the order, root first, then tip.


Don't forget to enter values for the group inputs in the Geometry Node modifier's settings (see screenshot on the right side). The values depend on the size of your model. For a default cube, try something like 0.03 for the root and 0.0 (or 0.01) for the tip.

Important Setting for the Viewport and Eevee

To see the thickness of the hair curves in the viewport and Eevee rendered images you need to set the Curves > Shape option to Strip. (In older Blender versions Curves is labeled as Hair)

Strand = Render curves as a thin strand roughly a pixel wide. Curve diameter parameters are ignored with this setting.

Strip = Render curves as a flat ribbon with rounded normals.

Cycles always respects the cure diameter parameters.

  • $\begingroup$ Thanks so much! I'll check this out. $\endgroup$
    – Brian Life
    Jul 24, 2022 at 14:26
  • $\begingroup$ Unfortunately I set this up but its not working. No thickness is showing. that odd. I did all settings right. ibb.co/30N3SxP $\endgroup$
    – Brian Life
    Jul 24, 2022 at 14:51
  • $\begingroup$ Hi. Why do you have the Group Input slots To Min and To Max 2 times? You can remove them in the side panel of the node editor. Select the vertical Group tab. Do you have entered values for the group inputs in the modifier's settings (see my screenshot, on the right side). Try 0.03 for the root and 0.0 for the tip. The values depend on the size of your model. Oops, I forgot to mention the Eevee setting... Give me a second. $\endgroup$
    – Blunder
    Jul 24, 2022 at 15:08
  • $\begingroup$ Make sure to set the Curves > Shape option to Strip. Otherwise, you will see the effect only when you render with Cycles. $\endgroup$
    – Blunder
    Jul 24, 2022 at 15:37
  • $\begingroup$ I can not delete the double Max/ Min, I forget how I got them exactly. I unplugged them and re- plugged them in and it added 2 .. I think. I tried in the N, vertical panel aria, I don't see how to deletes them $\endgroup$
    – Brian Life
    Jul 25, 2022 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .