2
$\begingroup$

For GPU rendering I use a GT 650 Ti Boost. Strangely, rendering jobs consume all my CPU time so anything else I do on the computer is just as choppy as when I do a CPU render.

I have Blender configured to use 6 of 8 cores when it does use the CPU but that doesn't help either. It's an FX8350 CPU, with 8 gig of RAM, so that should be lots of horsepower too.

Since there are guides for setting up multiple instances of Blender to handle GPU/CPU renders on alternate frames I would expect the CPU to remain largely free during a GPU-only render.

Does anyone have insight/tips as to why it's sucking up more resources than it probably should?

$\endgroup$
  • $\begingroup$ I would expect the CPU to remain largely free during a GPU-only render. Not quite. Even on GPU rendering, there are still a lot of operations and complex math that are computed by the CPU (like physics or particles for example). To get better performance out of your machine the best way is to optimize or simplify your scene as much as you can, bake and organize render layers and passes, etc. But at the end, if you are rendering very heavy or complex scenes, don't expect your computer to be as responsive for other tasks, let it do it's job. $\endgroup$ – cegaton Mar 11 '15 at 9:33
  • $\begingroup$ If you are rendering on the GPU which you also use to display your desktop, desktop rendering may become very laggy. Are you sure your CPU is the problem here? $\endgroup$ – maddin45 Mar 11 '15 at 10:59
  • $\begingroup$ It ends up being maxed out, but I can see the video lag being the culprit for visual updates. I find it odd that the CPU will still max out when the scene has had the animation/physics baked previously. $\endgroup$ – Casey Wagner Mar 11 '15 at 16:58
  • $\begingroup$ I'd consider this answered well enough to close. Though without an answer below I don't see an option to do so. $\endgroup$ – Casey Wagner Mar 11 '15 at 22:54
5
$\begingroup$

I'm certainly no expert, but I had a 95% CPU usage whilst rendering, even though I had chosen GPU Compute from the Render section. What I didn't realise, was that I also need to select CUDA in User Preferences/System too. After that I re-did the same Render and the CPU then hovered around 15% as expected. V 2.79 if that makes any difference. Will be interesting in the forthcoming version of Windows which supposedly will show the GPU usage in the Task Manager.

$\endgroup$
  • $\begingroup$ This did work for me, currently only 20% CPU usage (on i7 though) Interesting is that GPU usage is still only 4% and render times are even slightly slower then before, but I guess that's another issue. $\endgroup$ – Paul Feb 22 at 22:08
  • $\begingroup$ For others that wonder (and are on the same path as me), I found that increasing the tile size greatly improves the render times with GPU; see also (gregzaal.github.io/auto-tile-size) $\endgroup$ – Paul Feb 22 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.