Is there any way to fix that ugly look created by shade smooth? Can I use auto smooth directly in geometry nodes somehow? Because it looks okay with auto smooth, but it is possible only when nodes are applied.



1 Answer 1


This can't really be avoided when extruding a mesh with Extrude Mesh.

There is, however, an approach with Geometry Nodes that will give you a correct smoothing: Curve to Mesh.

However, you would have to do it structurally a bit differently:

enter image description here

Here I first extrude the letters with Curve to Mesh, but without Fill Caps.

I create the caps manually by placing the letters at the start and end points of the curve along which the letters are extruded.

To make sure that the mesh is closed and has correct normals, I apply the node Flip Faces and Merge by Distance to connect the individual elements correctly.

  • $\begingroup$ Let's hope Normal manipulation comes to GN soon $\endgroup$
    – Robin Betts
    Jul 20, 2022 at 20:43
  • $\begingroup$ @RobinBetts Oh yes, I think there are some important nodes on our wish list by now ;-) $\endgroup$
    – quellenform
    Jul 20, 2022 at 20:47
  • $\begingroup$ I don't seem to be seeing differences between extrusion and your method. I'm bending it along a curve $\endgroup$
    – Eneary
    Jul 20, 2022 at 20:53
  • $\begingroup$ I found a way to do what I wanted. I just need to make that text with auto smooth enabled and just put it as an object then I will have a nice smooth text that I can bend along the curve inside geometry nodes. Guess I can call this a semi-procidural technique $\endgroup$
    – Eneary
    Jul 20, 2022 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .