0
$\begingroup$

I am making a game on the BGE with smooth shading pretty much everywhere. Everything looked great until I added a title screen scene. Then, whenever I switched between them while running the game, the shading meaninglessly switched between boxy and smooth, while also omitting some graphical toon effects. Is there a beter way to do this?

Here is the file:

This is with boxy/flat shading and absent graphical toon effects: How its supposed to not look: This is good, but still missing some toon styling: Better This is with all the real effects, loaded directly from the adventure scene: No title screen, but perfect

$\endgroup$
  • $\begingroup$ I also note that more graphical effects are missing when I start the game in the title scene and use an actuator to set scene to the adventure mode. When I ran the game in adventure mode, it had all the effects and toon shading I need. $\endgroup$ – SilverRain Mar 10 '15 at 23:47
  • $\begingroup$ Did you make sure both scenes were set to GLSL shading mode? $\endgroup$ – Scalia Mar 18 '15 at 23:37
2
$\begingroup$

This is because any new scene created is automatically in Multi-texture shading mode and the other scenes you go to will adopt that setting. you need to change the menu scene's shading to GLSL even if the play scene already is. You can't play a game in two different shading modes.

Here's the .blend I made up for you, there are instructions in the text area to the right.

$\endgroup$
  • $\begingroup$ @SilverRain does this work? $\endgroup$ – Scalia Apr 5 '15 at 3:29
  • $\begingroup$ Sveet, glad o see you back $\endgroup$ – Scalia Sep 17 '15 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.