2
$\begingroup$

I used a physics simulation to make sure these objects sit on the floor. Here is what it looks like from my camera view

enter image description here

Here is an Eevee render. Looks good:

enter image description here

Here is a Cycles render. You can see the objects are now clipped into the floor.

enter image description here

How do I fix this?

A commenter in another question mentions displacement. Could this be causing it?

enter image description here

I got the material from online and this is how it came as default.

$\endgroup$
2
  • 2
    $\begingroup$ From the image, It's the displacement is not the same in eevee than in Cycles. Instead of that, use Bump $\endgroup$
    – Emir
    Jul 19, 2022 at 13:36
  • $\begingroup$ You could also try adjusting the Midlevel down by eye. $\endgroup$ Jul 19, 2022 at 20:51

1 Answer 1

2
$\begingroup$

As of 3.2.1 Cycles supports displacing the mesh itself with the Displacement node, Evee does not. This can be changed in the Material Properties > Settings > Surface panel.

Setting the Displacement option to Bump Only will cause the Displacement node to behave in Cycles the same way it does in Evee.

In Evee, you just have to add a Displace modifier and plug in the same texture, and it will look like it does in cycles.

So to fix your problem, I'd guess you should switch to Cycles and set the Material to Bump Only, since your mesh isn't subdivided enough to take advantage of displacement.

Material settings

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .