I have rendered the animation in eevee and cycles but the rendered video (output) is only a gray background please help soon it works fine in workplace render this:enter image description here

EDIT: A workaround? if i copy all my objects to an another file (created new blender file) then rendered it works but that still does not tell me why this is happening.

my prefences: enter image description here

file here for your ref:https://drive.google.com/file/d/1-NUUK_sybn7VVQ2-wfU0V8vS7tcxV9U2/view?usp=drivesdk file link

  • $\begingroup$ How to include file? $\endgroup$
    – Raven-Sus
    Jul 16, 2022 at 16:27
  • $\begingroup$ Show us your background setup $\endgroup$ Jul 16, 2022 at 16:33
  • $\begingroup$ how to i am new $\endgroup$
    – Raven-Sus
    Jul 16, 2022 at 16:41
  • $\begingroup$ please share your file (remove all the useless objects and pack the images): blend-exchange.com $\endgroup$
    – moonboots
    Jul 16, 2022 at 16:50
  • $\begingroup$ Does this answer your question? When rendering an image the output is grey $\endgroup$
    – Emir
    Jul 16, 2022 at 17:39

2 Answers 2


The collection containing your models is disabled for rendering:

collection rendering disabled

Hence, all objects contained inside, including your bird and the green cube, were just not being rendered, leading to only your scene world's gray color to be visible.

Enable the collection's rendering and it will work normally.

Unrelated note: if you put a green cube behind your bird in order to key out the green for transparency in a later use, that's unnecessary.
Enable transparency in Properties Editor → Render tab → Film panel. Then in your file output, make sure you use a file format that supports RGBA colors like EXR or TGA.

  • $\begingroup$ I did not see that wow I was so stupid thank you $\endgroup$
    – Raven-Sus
    Jul 17, 2022 at 8:57

In the Output Properties tab, there is a dropdown called Post Processing.

Enabling the Compositor checkbox might solve your problem.

enter image description here

  • $\begingroup$ Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center. $\endgroup$
    – Community Bot
    Jul 17, 2022 at 8:11
  • $\begingroup$ I have checked that thank you for telling the comment above was the answer but still thank you very much and have a great day $\endgroup$
    – Raven-Sus
    Jul 17, 2022 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .