1
$\begingroup$

I did a nice little motion track:

Motion Tracked

I want to apply a glossy material with a little bit of roughness to give it a metallic look, and in the reflection of the metal, I want to see the surrounding environment. I plan on using a still image from the original footage and applying it as an environmental texture (in Cycles). Is there any way to make it so the environmental texture only influences the reflection, and has no influence on the lighting? If so, please explain to me how this can be accomplished. Thanks!

$\endgroup$
1
$\begingroup$

If you only want reflections from an object or world texture, deactivate everything but glossy in object's or world's ray visibility :
enter image description here

$\endgroup$
  • $\begingroup$ He is using it for motion tracking, if he is using a mixture of Diffuse and Glossy he should absolutely use the Diffuse setting, transmission and volume scatter are less necessary. Using the world settings might work for him, but for more complex projects I'd recommend not messing with them. World settings should not be fiddled with if it can be helped, it is better to keep things localized. $\endgroup$ – VRM Mar 9 '15 at 20:09
  • 1
    $\begingroup$ i agree, but this is the simple and easy version, good for testing, understanding and basic setup. The world is an exemple. I didn't think it was necessary to add a screenshot with an object as the principle is the same. $\endgroup$ – Bithur Mar 9 '15 at 20:59
1
$\begingroup$

Not that I know of, however you can add a sphere, add the texture to it using a Diffuse material, and then disable the Shadows option.

Add a UV Sphere to your scene (Shift+A), and scale as desired (S).

Now go into edit mode (Tab) and select all (A) and unwrap using sphere projection (U > Sphere Projection)

Sphere Projection

Now set up your material like this:

Material Setup

Now all you need to do is to disable the casting of shadows. Go to Object > Ray Visibility and disable the Shadow option and the Camera option.

Shadows

If the reflections are not quite apparent enough you can try setting the material of the sphere to an Emission shader instead of Diffuse and tweaking the value.

Here are my results:

Diffuse

Diffuse Example

Glossy

Glossy Example

$\endgroup$
  • 2
    $\begingroup$ Thank you for your detailed response. I enjoy the convenience that having a Blender Stack Exchange website brings, and thank you for your input. $\endgroup$ – Anson Savage Mar 9 '15 at 23:48
  • $\begingroup$ No problem, glad to help $\endgroup$ – VRM Mar 9 '15 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.