2
$\begingroup$

H i , Local view or ( / ) hotkey changes view port (zooms out or in or rotates the scene) , is there any way to disable this behavior ? I want my viewport to remain still when im working .

It is cool though but in some situations it just not needed .

$\endgroup$

2 Answers 2

3
$\begingroup$

Yes. There is an option, 'frame selected', that you can change in the shortcut by going to the keymap panel of preferences and finding the Local View shortcut:

Local View in Preferences Keymap

"Frame Selected" may be "grayed out" but if you click on the checkbox to unset it, it will deselect.

$\endgroup$
8
  • 1
    $\begingroup$ I must speed up my image editing... :^) $\endgroup$
    – John Eason
    Jul 6 at 17:46
  • 1
    $\begingroup$ @user256371. According to the "answered N mins ago" tag on the answer I was about 6 minutes faster than John, but 'accepted' should go to the best answer, not the quickest, so if you think John's more comprehensive answer was better you should award it to him rather than me. $\endgroup$ Jul 6 at 17:52
  • 1
    $\begingroup$ You can give that one to @Marty Fouts since he beat me by 6 minutes. :^) Incidentally his final comment about leaving it enabled for one of the shortcuts doesn't seem to work as I mentioned in my answer! That's why it took me so long as I was checking how it worked! $\endgroup$
    – John Eason
    Jul 6 at 17:53
  • 1
    $\begingroup$ @JohnEason if my answer is less comprehensive than yours, then you should get the check. Meanwhile I'll remove the erroneous comment. $\endgroup$ Jul 6 at 17:54
  • 1
    $\begingroup$ @MartyFouts No problem. It looks as if both entries should be enabled/disabled together so that seems to be a display bug! $\endgroup$
    – John Eason
    Jul 6 at 17:57
4
$\begingroup$

You can disable the framing (zoom, etc.) in the keymap editor. Search for local on the Edit > Preferences > Keymap Tab and uncheck Frame Selected under either of the Local View Keyboard entries as shown below.enter image description here I suspect there might be a bug there because I'd have expected it to only disable that action for one of the keypress types (main keyboard or numpad), but in fact unchecking either will disable framing for both although the other one is still checked.

$\endgroup$
1
  • $\begingroup$ I saw the answered time , and it seems like martyfouts did it 7 mins faster , although your answer was more comprehensive , and very much thank you . ♥♥♥ $\endgroup$
    – user256371
    Jul 6 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.